What has to be done to make blender static meshes ready for UE4 use?

Basically, I have downloaded .3ds models from the internet. They are ready models and have different textures to use. Using blender, how do I choose the texture and maybe add a UV map and lightmap (if that is necessary)? Please provide a step by step explanation as to how to make it ready for .fbx export to unreal and any other steps required in UE4 thereafter.

I have uploaded an example file that is similar to all the other files I’m trying to use.

Note: Please don’t link me to some other forum, because I have watched countless tutorials and read countless forums. I already know all the things that have to be done. I just don’t know which are necessary in my case.

[link text][1]
[1]: 22959-35ef16c7ef8c89b1dddc88765186b1cc.zip (2.06 MB)

  1. open it in blender and choose smooth at shading → left side of the viewport
  2. Add a lightmap () and probably also a collision ()
  3. export it
  4. import the fbx file + the textures
  5. create a material and add the textures to it
  6. apply the material to the mesh

A new, community-hosted Unreal Engine Wiki - Announcements - Epic Developer Community Forums :wink:

Thank you!

You have not only made my day,but my whole month! I never realized the answer was this simple. By the way, my missing part was creating the material in Unreal instead of Blender.

Sorry to bother you, so even though everything seems to be fine. But should I bother with these warnings (shown below)?

Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the ‘Export Smoothing Groups’ option in the FBX Exporter plug-in before exporting the file. Even for tools that don’t support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

Warning: The imported mesh is very small. This is most likely an issue with the units used when exporting to FBX.

Thanks! No more warnings. No worthwhile difference though.

To fix the “very small” issue, you could try using a 10 or 100 for the Scale in the export window on the left side:


For the smoothing, does this look like yours?


With this i don’t get this error. (Can also be found on the left side of the export window: