What can be done to lower UE4Editor startup time?

Status: the problem lowered, but compared to other users reports it persists.

I have moved to UE4.27.0 and the startup time lowered from 11 to 6 minutes! (the RAM usage lowered too!) But doesnt compare to the speed other ppl report…

It is not compiling anything, not even shaders, it is like the 4th time I run it for one project.

Should I try to disable plugins? but Im UE newbie and dont want to difficult my usage. Tho, for ex., I have nothing VR related to test so it could really be initially disabled.

    I have tested moving UE4Editor whole engine path (100GB) to a 3xSSD(Stripes), but the UE4Editor startup time remained the same. My HD were it is too, is fast but not so fast as the 3xSSD.

  2. CPU USAGE? MAY BE if it could use 4 cores could solve it?
    UE4Editor startup uses A SINGLE CORE ONLY, i can confirm with htop and system monitor, it is possible to see only a single core being used 100% and it changes between the 4 cores, so only one is used at 100% per time.
    I tested this command line parameter -USEALLAVAILABLECORES after the project URL for UE4Editor, but nothing changed. I read that option is ignored in some machines, so may be if I patch it’s usage it could work on mine?

  3. GPU? no?
    a report about an integrated graphics card (weak one) says it doesnt interfere with the startup time.

LOG for UE4Editor v4.27.0 with the new biggest intervals (“…” means ommited log lines to make it easier to read; “!(interval in seconds)” is just to easy reading it (no ommitted lines here)):

[2021.09.15-23.38.20:677][  0]LogHAL: Linux SourceCodeAccessSettings: NullSourceCodeAccessor
[2021.09.15-23.38.42:780][  0]LogTcpMessaging: Initializing TcpMessaging bridge
[2021.09.15-23.38.42:782][  0]LogUdpMessaging: Initializing bridge on interface to multicast group
[2021.09.15-23.38.58:158][  0]LogPython: Using Python 3.7.7
[2021.09.15-23.39.01:817][  0]LogImageWrapper: Warning: PNG Warning: Duplicate iCCP chunk
[2021.09.15-23.40.16:951][  0]SourceControl: Source control is disabled
[2021.09.15-23.40.26:867][  0]LogAndroidPermission: UAndroidPermissionCallbackProxy::GetInstance
[2021.09.15-23.40.42:325][  0]LogAudioCaptureCore: Display: No Audio Capture implementations found. Audio input will be silent.
[2021.09.15-23.41.08:207][  0]LogInit: Transaction tracking system initialized
[2021.09.15-23.41.17:513][  0]BlueprintLog: New page: Editor Load
[2021.09.15-23.41.40:396][  0]LocalizationService: Localization service is disabled
[2021.09.15-23.41.45:457][  0]MemoryProfiler: OnSessionChanged
[2021.09.15-23.41.58:497][  0]LogCook: Display: CookSettings for Memory: MemoryMaxUsedVirtual 0MiB, MemoryMaxUsedPhysical 16384MiB, MemoryMinFreeVirtual 0MiB, MemoryMinFreePhysical 1024MiB

I’m using ubuntu 20.04.
My CPU is 4 cores 3.6GHz.
GeForce GT 710 1GB.

Related question but for older UE4: Extemely slow startup time for game projects(Ubuntu 20.04) - Platform & Builds - Epic Developer Community Forums

PS.: There is some talk already here: What can be done to lower UE4Editor startup time?