Download

What can be done to lower UE4Editor startup time?

Status: the problem lowered, but compared to other users reports it persists.

I have moved to UE4.27.0 and the startup time lowered from 11 (v4.26.2) to 6 minutes! (the RAM usage lowered too!) But doesnt compare to the speed other ppl report “almost instantly”…

It is not compiling anything, not even shaders, it is like the 6th time I run it for one project.

Should I try to disable plugins? but Im new with UE and dont want to difficult my usage. Tho, for ex., I have nothing VR related to test so it could really be initially disabled.

  1. HD READ SPEED? NO
    I have tested moving UE4Editor whole engine path (100GB) to a 3xSSD(Stripes), but the UE4Editor startup time remained the same. My HD were it is too, is fast but not so fast as the 3xSSD.

  2. CPU USAGE? MAY BE if it could use 4 cores could solve it?
    UE4Editor startup uses A SINGLE CORE ONLY, i can confirm with htop and system monitor, it is possible to see only a single core being used 100% and it changes between the 4 cores, so only one is used at 100% per time.
    I tested this command line parameter -USEALLAVAILABLECORES after the project URL for UE4Editor, but nothing changed. I read that option is ignored in some machines, so may be if I patch it’s usage it could work on mine?

  3. GPU? no?
    a report about an integrated graphics card (weak one) says it doesnt interfere with the startup time.

LOG for UE4Editor v4.27.0 with the new biggest intervals ("…" means ommited log lines to make it easier to read; “!(interval in seconds)” is just to easy reading it (no ommitted lines here)):

[2021.09.15-23.38.20:677][  0]LogHAL: Linux SourceCodeAccessSettings: NullSourceCodeAccessor
!22s
[2021.09.15-23.38.42:780][  0]LogTcpMessaging: Initializing TcpMessaging bridge
[2021.09.15-23.38.42:782][  0]LogUdpMessaging: Initializing bridge on interface 0.0.0.0:0 to multicast group 230.0.0.1:6666.
!16s
[2021.09.15-23.38.58:158][  0]LogPython: Using Python 3.7.7
...
[2021.09.15-23.39.01:817][  0]LogImageWrapper: Warning: PNG Warning: Duplicate iCCP chunk
!75s
[2021.09.15-23.40.16:951][  0]SourceControl: Source control is disabled
...
[2021.09.15-23.40.26:867][  0]LogAndroidPermission: UAndroidPermissionCallbackProxy::GetInstance
!16s
[2021.09.15-23.40.42:325][  0]LogAudioCaptureCore: Display: No Audio Capture implementations found. Audio input will be silent.
...
[2021.09.15-23.41.08:207][  0]LogInit: Transaction tracking system initialized
!9s
[2021.09.15-23.41.17:513][  0]BlueprintLog: New page: Editor Load
!23s
[2021.09.15-23.41.40:396][  0]LocalizationService: Localization service is disabled
...
[2021.09.15-23.41.45:457][  0]MemoryProfiler: OnSessionChanged
!13s
[2021.09.15-23.41.58:497][  0]LogCook: Display: CookSettings for Memory: MemoryMaxUsedVirtual 0MiB, MemoryMaxUsedPhysical 16384MiB, MemoryMinFreeVirtual 0MiB, MemoryMinFreePhysical 1024MiB

Obs.: the other ppl I talked to were not specific, if they had persistent (not first) UE4Editor long startup time, on linux, so I guess this problem may happen on windows too. But as I only use linux, I guess it is better to get help from other linux users.

SPECS:
I’m using ubuntu 20.04.
GeForce GT 710 1GB.
motherboard: GA-970A-UD3
RAM: 6GB DDR3 1600MHz
CPU: AMD FX™-4100 Quad-Core Processor 3.6GHz

OBS.: Original question at: what-can-be-done-to-lower-ue4editor-startup-time (but it is waiting approval for a few days, so I dont know when it will show up to others, should I delete it there?)

PS.: if I cant edit this post and succeed, look for OP_UPDATE on this thread.

Sounds like it’s software raid.
IF so, are you sure it’s actually X3 on the bus speed ?

What is the mobo?
Can you buy yourself an m.2 NVMe/PCIe to use with actually higher bus speeds?

Check what you can use based on the max bus speeds:

  1. SATA II Connector 3 Gb/s
  2. SATA III Connector 6 Gb/s
  3. PCIe 2.0 x4 16 Gb/s
  4. PCIe 3.0 x4 31.5 Gb/s
  5. M.2 PCIe 3.0 x4 31.5 Gb/s

If you don’t have M.2, but your PCIe 2 or 3 slot is empty, you could (technically waste) money on a PCIe solid-state drive.
Why waste? Because at that point, buy a better mobo with an M.2 connector - or 2 for that matter.

what family/generation is your CPU, you just note it’s 4 cores. How old/new is it?

How much RAM do you have and at what speed?

motherboard: GA-970A-UD3
RAM: 6GB DDR3 1600MHz
CPU: AMD FX™-4100 Quad-Core Processor

the 3xSSD gave this read benchmark: 800,5 MB/s (100 samples) (ran a few times, max 850 MB/s)

motherboard: GA-970A-UD3
RAM: 6GB DDR3 1600MHz
CPU: AMD FX™-4100 Quad-Core Processor

these NVMe look amazing, didnt know about it. I wonder if my mobo will cope… thx!

Sooo, you will very likely want for a LOT of RAM. 6GB is low… Make sure you at least have a lot of swap space.

CPU is ~25bucks on Ebay. ~50bucks on Amazon. Seems older and I suspect it’s likely lack of support for some more advanced SIMD sets (and the like) on the CPU that is costing you.

Startup taking minutes seems long tho, even on a default map? What level are you opening?

NVMe is like magic sauce, I have one. TOTALLY worth investing in a new mobo for you if you can get that, else with the current system I feel you are just going to struggle overall with anything heavy.

When you open the editor what kind of FPS you get?

There are several issues here:

  • Your CPU is obsolete and insanely slow compared to a modern workstation CPU: AMD Ryzen 9 5950X vs AMD FX-4100 Quad-Core [cpubenchmark.net] by PassMark Software
  • You do not have enough RAM for the minimum requirements of Unreal Engine (recommended 32+)
  • Your RAM is very slow.
  • You aren’t using a NVMe SSD.
  • The editor starts slower on Linux than on Windows, supposedly because of issues loading all the modules.

I run windows 10.
My processor is i3 4150
Ram 4gb ddr 3
Maxtor Z1 240gb ssd
I have no issues in running ue4.27 and it boots up in a minute .

1 Like

4GB to start is one thing, but once you start actually doing things, it will go, quickly.

Thx, that I thought… I got a report about a low end PC being able to load it fast too.

Linux stuff I still need to try:

I have no windows (I dont want to install it).
I need to be able to run the UE Launcher windows executable on linux thru wine.
I read it can be run properly on WineHQ.
I extracted the launcher.msi with 7z x and I saw everything inside is 32bits.
Ubuntu 20.04 cant run 32bits Wine stuff, not even the installer, so I will try to run it in a 32bits schroot soon.
After that, I will download UE4.27 (64bits) for windows, copy it outside the schroot and try to run it on Wine 64bits.

I will do all that just to test the startup time, to be sure if I need or not to upgrade my hardware. Because if that is not the problem, I may upgrade my hardware and still have the same problems!!! So I dont intend to use the windows executable on linux as there is reports it doesnt work well: “Light building fails, you can’t resize the window unless you have enabled “virtual desktop” inside of wine settings, you can’t create c++ projects without installing windows version of visual studio and packaging the game also fails.” at https://www.reddit.com/r/unrealengine/comments/dagbj7/comment/f1pf690/?utm_source=reddit&utm_medium=web2x&context=3

Patching glibc:

I still think the problem may be related to the glibc implementation as reported:
The problem is at “dynamic linker (dl)” … “With the amount of plugins loaded in UE4 the dynamic linker gets slower and slower as it needs to continuously lookup and sort the symbols in each dynamic library that is loaded. We ended up patching dl to cache symbols in each loaded library ourselves which brought the load time down considerably though still not as fast as windows.” … “the solution was to rewrite _dl_sort_maps in glibc to reduce the amount of calls to dlopen OR reduce the amount of plugins that get loaded to what you actually need” at https://www.reddit.com/r/unrealengine/comments/nzia7z/comment/h1po2ys/?utm_source=reddit&utm_medium=web2x&context=3

Unfortunately they did not share it :frowning:

Can not confirm.
For me it starts noticeably faster on Ubuntu 20.04 (with 5.11) than on w10.

It’s all about bottlenecking.
Your machine is one solid bottleneck, no wonder nothing works for you.

Interesting. Maybe they fixed it. This was years ago now.

It was never broken.
Linux GPU drivers used to be 30-40% less efficient, but this is no longer a case.
Everything else just some times require careful tuning, but, more often than not, just not bloating your system is enough to get better performance.
Unless you are using a weird laptop, then tuning it is.

Or may be ms broke windows yet again.

Not sure how GPU drivers are relevant, it’s about this issue: https://twitter.com/btschaefer/status/1467339190052560897

Looks like they’re finally fixing it!

They come into play on shader compute - along with a decent speed cpu.

Other than that, I would assume slower drivers cause everything to run on less frames - not that it matters to engine loading times…