What are those triangles on my objects

So I followed a tutorial and Baked Light Maps and then these artifacts started appearing

I think you need to take a look at your lightmaps. Second channel ( channel 1 ) in the static mesh editor.

I couldn’t find that but I wanna ask, Is it still necessary to Bake lighting and everything else on Lumen and Nanite ?

1 Like

No. It never was necessary to bake lighting. Especially not now with Lumen.

You only need to bake light for 2 reasons

  1. It’s archviz, and you’re trying to squeeze every inch out of the engine

  2. For performance, you don’t want to use dynamic lighting. ( But then you can’t use Lumen ).

That looks very much like Z resolution acne. If there is a “bias” parameter for your shadow generation, try tweaking that. If you can set the depth channel format (I forget whether that’s a feature,) set it to float32, or another high-resolution format supported by your platform.

If not, then try arranging lighting that is less glancing angles to the surfaces.

Also, the resolution of those shadow maps seems pretty low for a close-up shot like that, you probably want to increase the resolution of your shadow maps (high number for static meshes, low number (size of luxel) for BSP geometry.)

Or turn off baking and run without pre-computed shadows. Modern GPUs with modern geometry can do very well in a non-baked world!

I see, without any optimization with only nanite it is having problems keeping up but I feel like the amount of Time it’s saving for me and the realism it’s bringing (Which i feel is better than Global Illumination) I feel like I’d rather optimize it and use Lumen

Sad thing is now I need to find how to remove those baked maps

I will check the things you mentioned above, and I totally forgot I needed to Increase the Resolution of the Shadow Maps

btw what’s a BSP geometry ?

and yess without baking just with Lumen it looked absolutely stunning too, It made me drop my jaw when I first switched to Lit mode, I still wonder how Epic team was able to achieve this huge difference

Binary Space Partition (in-engine CSG tools (Constructive Solid Geometry))
These guys:


Meanwhile, static meshes is pretty much any asset you import, as well as the stock mesh actors:

Thing is, you don’t need Nanite for a scene like this. That’s designed for large open world environments.

To remove them, just switch your directional light to moveable ( any point lights also ) and rebuild.

It’s Interesting, Kind of funny how I never thought that those 2 could be totally different things, Gotta Learn more about it

My scene is Pretty High Poly, 5-6Mn, are you sure I can turn off Nanite and It’d be fine ?

i had spot lights and Sun and Sky, I switched lights to movable and baked lighting but it’s still there, Maybe I will need to make a new file and reimport all datasmith files

Nanite is for stuff like the demo scene, where you have a ridiculous amount of similar rocks.

You have some cushions on the sofa :wink:

Now I’m starting to think along the same lines as @jwatte, it does look like Z fighting.

Do you definitely only have the number of articles you’re expecting in the scene? You haven’t dragged copies on top of each other by accident?

I see, so If i have many instances of a cushion or something similar to that scenario then it’ll be much more useful, Btw is blueprint only way to instance em

I just checked and there’s no copies. although it was crashing whenever I reloaded the datasmith file so i just deleted the original folder and then imported datasmith so it worked but any chance thats’s what caused this issue ?

You would need hundreds or thousands to make it worthwhile. You can instance them by selecting them all and right clicking, convert to static mesh ( instancing is in the options ).

I don’t use datasmith, so know nothing about it, but good to hear you fixed it. Sounds like it was at fault.

ooh then I will disable Nanite on it, in right click the option is duplicate which is i think what instance does,
sadly reimporting didn’t worked as seems like it’s something with lightmaps so I’m creating a new file and this time I’m not gonna bake anything

How do you do this? Thank you