Download

Weird shadows in simulation mode

Hi guys, I’ve got this shadow problem with a curtain but only when in simulation mode. I couldn’t find someone with the same problem so I’m trying it this way.
The material has it’s translucency through a mask, but I don’t think the weird shadows should have anything to do with the material itself.
Directional light is set to movable, Skylight is set to static but changing this to movable doesn’t change a thing.
The curtain mesh is a skeletal mesh. When simulating the curtain is softly blowing in the wind, but when I start simulating the weird shadows also begin to appear.
As you can see I’ve got the Volumetric Lightmap density bumped up pretty high and it hasn’t anything to do with the lightmap density
Also, the shadows aren’t moving when the curtain is blowing in the wind, they’re just stuck on the mesh.
I’m a bit of a beginner with Unreal Engine and I especially have no clue about skeletal meshes. Hopefully somebody can help…

Can be the “cast shadow” option under light settings in the curtain mesh?

It appears there’s a range of things that may be tried to correct it.

  1. Try check Use High Precision Tangent Basis and/or (meaning try one, then the other separately, and then both) in the Build Settings of the mesh.
  2. Try enabling Volumetric Translucent Shadow and/or Dynamic Inset Shadow.
  3. Modify the volumetric lightmap (the wrong combination of values can result in culling of sample points, or the big spheres that it’s comprised of, and thus weird shadows). Decrease detail cell size, and increase maximum memory brick data amount.
  4. There’s a setting in, I think it’s the material details panel inside the M.E., called “Cast Shadow as Masked”. If it’s not there, it is somewhere in the details panel when in the main editor, for the mesh.
  5. Enable “Shadow Two-sided” in the instance of the curtain under Lighting (final screenshot panel).
  6. Enable Lighting Channel 1 since a skylight is being used that is static, the lightmap is probably getting sent to Channel 1 from Channel 0 from the bake. Since it is disabled in the instance’s Lighting settings (final screenshot), it’s not using that lightmap most likely, so there’d be incorrect / incomplete data.

Just change lightmap type from surface to volumetric. Nothing complex or hacky.