Download

Weird shadow lines on object

Hi,

I’ve attached references for my issue. I’m having shadow lines on only one model. I’ve unwrapped the elements inside maya then combined them >> arranged the uv shells. It is obvious that the elements affects each other. I’ve imported the model >> generate auto lightmaps >> Overridden light map Res to 1024 ,even higher I’ve tried to manually uving a second UV set but the same issue keeps on.

when I import each element individually, the issue goes away even if i auto generate lightmaps inside ue4. I don’t like to do so as it is not the right way I think and I will end up with a crowded, full of mini pieces scene.

thanks all

Hi!

Maybe 1024 lightmap resolution is not enough for the combined mesh… it does look like low res lightmap with it’s blurry, inaccurate shadows…

Hi,

I’ve raised it to 4k it still there.

I feel that combined elements are affecting each other. The bad culster shadow size of one element equals To neighbor element size. Ive tried to import separate objects and make light map to 64

With 64 res separate objects have proper Lightmaps on them.
this leads to exclude Lightmap Resolution assumption

Try disabling Distance Field AO

how can i disable DFAO. I don’t have any skylight in my scene

Maybe you could export combined mesh right back to your 3d software and try to clean it up? Check if tere is no uv overlaps and try to reimport it? It seems strange especially horizontal lines at flat surfaces, like other mesh inside.

Hi all,

Here is a link to my fbx model link:

I initially thought it was a case of bad UVs/modeling, so I remodeled most of the mesh (minus the bevels). But when I went to lightmass to bake out a comparison image, the results looked the same.

Both are using 256 light maps, if you want to try my version of the model, here it is: KioskMain_Fixed.fbx - Google Drive

My guess is it’s something with the scene or lightmass setup. Try my model, see if the same issues occur.

Thanks, I will try it

Hi,

This is the result for my mesh on another machine running 4.19 I will try it later on my machine (4.20) to test further. Thank you all.

regards

Thank you all, LightMass was set to low settings. I’ve increased settings and it is resolved.