Download

Weird shading on deform mesh

I’m new to unreal, idk much about it. I made character, was testing blinks using bones and corrective shape keys. Seems like shadow “stretching” idk what is happening.



I disable all shadows on character but still, in lighting only mode you can see clearly

Some wireframes


I’m using Auto Rig Pro for work and export

P.S. By any chance do you know why Auto Rig Pro doesn’t export animations, i tried in nla strips and actions… nothing.

Its normal.
You need to properly set up your scene lighting and your mesh settings.
As well as enable compute skin cache.

1 Like

Thanks for replies. I enable compute skin cache “Support Compute Skin Cache” and visually nothing changed.
Before i did setting up light settings, currently i have: Directional Light 3,14 lux, SkyLight 1.5 intensity. Some info, i have enabled forward shading and distance mesh field, idk if its does something.
Also i noticed if disable Shape keys, that weird shading disappear but i dont want that trade.


Fixed it by enabling “Force all skinned meshes to recompute tangents”.

But wait! Some hard shading appeared on mesh…


Now how i fix that?!

Also, on my whole model UV seams look like hard edges, but in blender i don’t have anything like that.


What is going on?

Probably your actual seams.

Your textures have to be perfect for it to work. Normals and roughness included.
Dcc have higher precision than the engine (by a lot in all aspects of rendering).
You may need to increase the quality of the UVs either by making the UVs right (match up on the edge of a pixel so that the image is always perfect), or by changing the setting on the mesh.

Same with your actual mesh.
Smoothing groups have to be right, with hard edges where needed.
The issue on the shirt could be a rogue flat face or 2.

Overall, the mesh also has settings for lighting that you need to tweak. A lot. To get the shadows to play nice.

1 Like

Thanks alot for helping people!

This helped me, fix hard uv seams: https://www.reddit.com/r/unrealengine/comments/isyx7b/425_supporting_skin_cache_creates_ugly_seams_in/

But i ran into another issue…
All my hard shading is smoothed out now!




How can i fix THAT?!

Did some experiments: Only SKELETA MESH always have complete smooth shading, no matter methods(mark sharp/shade flat), you always will get smooth shading. But if i import it as usuall mesh(without skeleton), its fine.

Why only skeletal mesh? WHY IS THIS HAPPENING TO ME!? help

I don’t know what you did, but that’s probably not the correct way to address seams on Skin.

There was a forum topic I wrote in on with details, but thanks to the update finding it is a toss up.

In short, the material slot within the LOD section needs to have recalculate tangent checked, and the material itself has to derive tangent from normal map.

The clothing doesn’t need that, if on a separate material.

If using the same material, just bake the normal map in blender from a subdivided mesh onto a low poly one and use the produced normal - which will contain the hard lines.

1 Like