Download

Weird rendering problem.

It happens only from a certain distance, and as long as i getting more far away it escalates exponentially.
3e24b6afea107dea3e496826cfce939083c0f30e.jpeg

This is just a bunch of blueprints that has a cube mesh in it.
This is how the mesh looks like:
b11645630348d7718736c9797ba5dd46d3141922.jpeg

This game is an editor that allows you to build levels like minecraft, so this is why it has to be composed of multiple cubes.
I know the horizontal lines can be fixed with playing with the shadows settings, but what about all that weird artifacts?

Is that built lighting or dynamic?

Dynamic, but the problem is not the lighting, is the meshes getting messed up.

Easy way to find out, if it’s shadows it should go away if you turn off shadows.

The other possibility is that it’s z-fighting, if you have a large map then the depth is configured by that and the top faces could be fighting with the faces underneath them if they end up at the same depth level.

I see, they are very close indeed, is there anyway to keep the calculation of the z depth precise enough when been far from the object ?
Btw the faces that shares almost the same position are both hidden from the player ( not the top ones ) so it doesn’t matters who the engine things is first, both of theme shouldn’t be seen at all :expressionless:

Hi Sahkan,

Please post this to the answerhub at http://answers.unrealengine.com in the bug reports section so we can assist you in depth.

Those faces aren’t visible, but since it’s a static mesh it should still be rendered. The engine doesn’t hide faces of a static mesh that aren’t visible.

Alright posted : Weird rendering problem. - UE4 AnswerHub
Thanks.

I see, anyway you know to tweak this setting ?

The engine doesn’t support the option to hide invisible faces in a static mesh. The best you could do is code it manually, make a cube out of 6 planes and then have it hide them if they aren’t visible.

I think this is too weird that you can put a couple of objects together without getting artifacts, i will see how it goes in answer hub, thanks for the help though.

Is it adaptive tessellation? Are you trying to use a material with displacement? If so, try adding a node to the Tessellation Multiplier pin i the material editor set to 20 or something.

Nope, not using tessellation, thanks though.

It took some time duo to problems with my computer, but i’v answer the post in answerHub yesterday, just making sure you guys know about it:
https://answers.unrealengine.com/questions/198944/weird-rendering-problem.html