Weird looking shadows

No matter what I try, the shadows in my level look very bad. Has anybody a suggestion?

Yes I did. It looks like that even on production quality.

ok. it is city of brass. i dont know much about uvs but when i open the mesh i can see uv1 has some red lines going to nowhere. uv1 and 2 are empty. and in uv3 it looks ok as there are no red lines and the faces are ligned up nicely.
so i would have to export all meshes and fix the uvs? or is there another option?
edit: i moved uv3 to uv1 on that one wall mesh but it did mot make a difference.

I did that but it only made it worse. now the walls have vertical lines over them. and other meshes are also messed up.edit: i only edited 2 meshes

Did you build lighting in your level?

It’s because the city of brass stuff has the lightmap in the wrong UV.

UE is expecting it in UV1, but CoB has it in 3.

EDIT: I checked a few more assets. It’s often in UV1, in fact. Can you take a look at the lightmaps?

EDIT2: Is that even CoB? :slight_smile: Anyway, it’s either lack of lightmaps or too low lightmap resolution.

The red line one is UV 0, right. If there’s nothing else, then you need to build the UVs.


The source will be 0, because that’s the material UV, which is where UE gets it’s info from. Destination should be 1.

Tell me the name of the asset?

Is it one of these corridor/wall meshes? I built the lightmap from UV3 to UV1 like this:


because the map in 3 looked good.

i built the lightmap again from 3 to 1. the result is the vertical lines. i tried one thing again and enabled “overriden light map resolution” on the mesh and set it to 256, and now it is much better. the strange thing is, that i already tried that but with a value of 64. can i somehow scale all lightmaps at once?

i got it now to work as you suggested. the problem was that under “mesh asset->general settings->lighmap coordinate index” i had to set “1” also.
its better now, but the resolution of 64 gives me still no good result. is there a setting anywhere to increase all lightmaps size?

Your lightmap should make sense, so UV1 should look something like

IE, not lines flying all over the place, or a bunch of rubbish in the corner.

The save, of course. Then you can specify the lightmap res on each mesh, or override ( all at once ) in the level.

I tried all this with ‘Corridor_A_Wall_800c’. It didn’t look like your pictures at any point, but I built it with 64 and there was a big shadow down the middle. Then I forced it to 256 in the level and rebuilt. It looks fine.

To be clear again, you can force all the meshes to any resolution you want in the level:

Fixed :slight_smile:

I can be done globally in the level, but to do it globally for your whole project wouldn’t make sense. Because the lightmap res really depends on which mesh you’re talking about, and the large the res, the more memory gets eaten up.

forcing the resoution is what i did in the end. i wondered, if it can somehow be done globally. but selecting all static mesh actors in the scene and applying the override did work well. thanks for your help.
edit: i would like this question to be solved, but it seems i cant do that on a comment. you could make a answer of your comment and i will mark it solved.