Download

Weird lightmap problems

Hello,
I’m new to UDK and I’ve been struggling to get my static meshes’ lightmaps right.

Here’s how is my workflow going:

  • Model and uv unwrap in Blender (diffuse and lightmap uvs) and check normals.
    screenshot.10.jpg
    (lightmap uv displayed)

  • Export to FBX.
    screenshot.11.jpg

  • Import to UDK4, check if mesh is using the right UV for lightmapping. (second channel)

  • Apply materials.

  • Put mesh on level and build lightning.
    screenshot.9.jpg

It doesn’t matter how I unwrap the lightmaps (even on automatic - the one that separates each face), it always has some kind of weird artifact like the one on the upper part of the door or visibly incorrect shadows/lights. I even tried to place it in a blank scene with default lights, no luck.
I’ve already read a great amount of tutorials and tips on how to proceed on this, but nothing seems to help it.
What can I possibly be doing wrong? :expressionless:

Thank you for reading! :smiley:

welcome to the forum:D

what happens if you increase the lightmap resolution and then rebuild lighting?

automated UV systems hardly ever give perfect results.

a few things about your lightmap: I notice you would have a much cleaner lightmap UV if your model was optimized a bit better(check [this thread](https://forums.unrealengine.com/showthread.php?63969-Need-help-with-unwraping-() for more info(it would also be easier to unwrap it)), you don’t need to separate the UV into that many UV islands, and you might want to straighten up the skewed parts of your UV as it can give skewed shadows.

hope that heps:)

ps. there is no UDK4, its just UE4;)

Weirdly enough, I re-exported the mesh as an .obj from Blender and the problem is gone (no need to reunwrap, but I do get your point… the map was not optimized at all because it must be the 99th time I did it from scratch and I was becoming a little unpatient hehehe).
It seems that this is a problem with FBX export in Blender or some missing setting… still confused about it :S

Unfortunately, I tried the same with other problematic objects, like the one below (which has a nice uv layout) but still get weird results. This time they are more traceable at least, since they lie in the uv seams:
screenshot.12.jpgscreenshot.13.jpg

What is driving me crazy is that it has almost the same uv configuration of other similar objects in sample scenes and they look perfect (like the couch in the RealisticRendering scene from the “Learn” scenes):
c15dc03008fd1a89fedfe0f061e87f8c96c65a43.jpeg

ue4 that is! that must be the reason why I’m having such a hard time finding info on the internet :frowning:

Ok, so I imported this premade couch on my scene and… surprise! Same problem.
So this is probably a problem with my light setup or some setting I don’t know about yet.
Any suggestions?
db42c49e9d774d92e33301e9b3dffc3c83cfd667.jpeg

On the door–you can get much better lightmap UV’s, you don’t have to separate out the frame, it’s wasting space.

The main issue though is that you probably have the default lightmap resolution, which is too low.

The low lightmap resolution was exactly the problem!
Thank you!