Download

Weird lenticular glitch?

Has anyone seen something like this before? It appeared on my horizon after I added a new mesh to my scene, but it doesn’t go away if I delete the mesh. I can’t seem to get rid of it. I’ve also tried deleting some of the lighting elements, but nothing has any effect.

It is not an object or mesh in the scene. There is no way to click on it, it’s not in the World Outliner, and here’s the weird part – when I move the camera around it follows my view, as though I were holding a lens in front of the camera. Even playing the game in VR, there it is, sliding around the horizon when I look around.

I’ve tried quitting the engine and restarting it, but it doesn’t go away. It’s even there in the thumbnail for the project in the engine library (second image).

I’m new to Unreal and game development in general, so I’m sure I did something wrong… but I can’t imagine what.

lenticular_glitch.PNG

99f606bd1961f74abf3d220707719df98128f253.png

Update: Well, I fixed it. I deleted the project from the engine, restored the previous check-in from github, and then reimported it to Unreal. I then added back the missing assets, and … the glitch didn’t reappear. Yay! Unfortunately this means I still don’t know what caused it.