Weird glow on moving material

Hello, I’m trying to make a rotating “target” material (for enemy marking), but the material is acting very weird. I have a target texture that I use (via texture sample) to set the opacity and color of the material. Since it is rotating, I do have to disable wrapping for the texture, that way I don’t get weird results. However, after applying all the above, a mysterious glow is appearing on my texture:


The dark red lines are really bugging me here, I checked the texture and there aren’t any small red pixels on the edges, and I don’t think rouge pixels are behind this, because when I zoom in and out this happens:



When I zoom out, the glow intensifies, and when I zoom in, the glow weakens. This is really bothering me, anybody know WTFlip is going on? (Quick note, all of the screenshots were taken while the material was rotating, so no, this is not the static look of my texture, the static look of my texture looks like this:

I’ve simply shown you rotated pics because it gives the best look at the glowing)

How are you rotating the texture?

I use a rotator node


(I’ve tested unplugging the RGB from the material inputs, and it doesn’t matter which way I plug them in, they always show the weird glow)

Now that I look at this, I notice that the weird glow is happening all around the texture (You might have to zoom in to see it):


So maybe, since the texture is “clamped”, the glow on this texture is on the edge, which then gets expanded to infinity because of the clamped settings. But there is still the issue of why this glow exists. The original texture doesn’t have this.

Doing some more testing, I see that this glow is affecting any material that uses a texture that stretches to the borders of the image:


(Original Texture takes up the whole image, glow appears)


(Original Texture does NOT stretch to the edge of the image, glow doesn’t appear)

Maybe I just need a way to tell the rotator to not fill in beyond the image

Only plug the red into opacity.




Unfortunately, this doesn’t appear to work :frowning:

K, I looked at this question: [How do I prevent texture from being pixelated? - Rendering - Epic Developer Community Forums][1], and It said something about mipLevels, IDK what those are, but I modified mine, and the image lost it’s weird glow, and subsequently so did the material! :smiley:

Previous mipLevel:


New mipLevel:


The Texture Sample was giving a pixelated version of the original image, which caused the “weird glow”. Since I was clamping my image, the rotator was extending any pixels that where on the border of the image. By changing my mipLevel (whatever that is), it gave me a more high-quality texture, and the weird glow disappeared, so now my target rotates normally :DDDD. Thank you ClockworkOcean, for helping! I wouldn’t have noticed the pixelating issue without you :slight_smile: