Weird Bug on Water Body using VR headset

Hello there,

I tried using the water system of Unreal 4 on a VR project, everything looks great. I used a simple landscape, but when I play it in VR mode it looks like some areas are cut and it bugs the view on the VR headset.

Viewport:

VR Mode:

Any thoughts of what this could be?

Have same problem, and I don’t find any information how to fix this.
Have searched all google already.

Have any luck maybe to find solution ?

BUT if you disable VR “Instanced Stereo” under project settings.
It works, but probably very ‘‘costly on FPS’’ .
Please EPIC GAME fix water on Virtual Reality :smiley: :grinning:
You need my game on your engine :innocent:

1 Like

This issue is known and being addressed for 5.0. Disabling instanced stereo can work as a temporary solution to your project, especially if you’re not draw call bound.

1 Like