Download

Weird artifacts with SSR/overall reflections

Hey, everyone.

I’m having a spot of bother with the engine.

HtSRizv.png

  1. There are some weird double-reflection-type thingies going on here. It seems the windshield is reflecting itself on itself. This only happens at certain angles, like this one. If viewed perpendicularly, it’s okay.

  2. I don’t know what’s reflected here, but it’s not in the scene. If I move the camera, I get a screen door effect.

Some other things I’ve noticed:

  1. The high resolution screenshot is pretty bad. What’s up with that?

5fb61ffe8913dadf6d4edb0e35cb67681989f9d3.jpeg

  1. Is there any way to attenuate the jaggies? I’ve tried Temporal AA and FXAA, all the settings cranked up, but nothing works.

This is my first time digging this deep in the engine for visualizations and it’s wonderful.

is there refraction on your glass?

Tha windshield is the refraction in your glass material. https://docs.unrealengine.com/latest/INT/Engine/Rendering/Materials/HowTo/Refraction/

Regarding the other artifacts…do you have distance field AO enabled by any chance? And what kind of lighting are you using(static/dynamic)?

Thanks, @tehtehteh and @Jacky, the refraction was enabled on the material, really missed it.

As for the DFAO, it’s not enabled. The car is movable, the backdrop is static.

I think I narrowed it down to SSR.

With SSR:
Untitled1.png

Without SSR:
Untitled2.png

I think it’s because the two surfaces are relatively close, so they reflect off each other ad infinitum.

Also, it might be the angle?

Untitled3.png

Make sure you are at Epic settings. Also, try these: r.SSR.Quality 4 and above (careful, performance hungry), r.SSR.Temporal 1 (will make them blurrier, but may help with your issue). SSR is reflecting only what is on screen, and I don’t see any striped patterns in your scene, so may be a bug.

Apparently, it’s a bug with r.SSR.Quality. More to the point, the SSR shader. I modified the NumSteps and NumRays to 32.

If I switch back to SSR_QUALITY 3, where NumSteps is 8 and NumRays is 4, the problem sort of disappears (ie. it becomes blurred).

Well, maybe not a bug, perharps it was never meant to be used with those values. But Epic people would know this for certain. Anyhow, good that you managed to fix it.