Web Browser Widget not working with Widget Interaction Component in VR

The Widget Interaction Component (WIC) doesn’t seem to be working correctly with the Web Browser Widget in 4.18.3
I have tested this with VR, with both the Epic Games Published version of 4.18.3, and also the Github Source.
The WIC is either able to click on the Web Browser, OR other widget buttons, but not both.

To see the problem, reproduce the following steps.

  1. Create a new project with the VR Default Template.
  2. Create a Widget with the Web Browser.
  3. Add some test buttons to the Widget alongside the Web browser.
  4. Add the widget to a new Blueprint, and place it in the level.
  5. Add a Widget Interaction Component to the player, and create it so it fires the “Press Pointer Key” node upon button press.
  6. Play the level.

When playing, you are able to hover over the Web Browser buttons, but cannot click anything in the web browser properly OR, you will be able to click on items in the Web Browser but cannot click on the Test buttons outside the web browser.

I have discovered that if two Widget Interaction Components are created, one of them will only work with the Web Browser, and the other will only work with buttons outside the Web Browser.

This may have something to do with the Web Browser plugin not being updated according to the addition of Widget Interaction Component Pointer Indexes.

A temporary solution to anyone else who has this problem, is to do the following:

  1. Make a Seperate Web Browser Widget Blueprint. Don’t put any buttons in this. Put your buttons in a different Widget Blueprint.
  2. Create a Widget Interaction Component in the BP_MotionController. On begin play, the default VRPawn will create the Left hand first, and the Right Hand second. This is important.
  3. In the VRPawn’s Blueprint, on Begin Play, you need to detach, move and attach the Left hand’s WIC to the right hand so that it has the identical transform the Right hands WIC.
  4. When your ‘click button’ is pressed, you want to get both WIC’s and check whether they are pointing at the Web Browser Widget. You can do this by following this screenshot:

  1. If your WIC’s are pointing at the Web browser, then you want to “Press Pointer Key - Left Mouse Button” for the WIC that originally came from the Left Controller (the WIC that was created first)
  2. If the WIC’s are not pointing at the Web browser, “Press Pointer Key - Left Mouse Button” for the WIC that originally came from the Right Hand (The WIC that was created last).

But doing this, you will essentially fix the issue.


We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.



Hello, I think this is still not resolved on 4.22, is there a bug report I can follow or any upates?


I’m also interested in progress on this issue.

When using the Browser Widget in VR, the Widget Interaction component seems to not have any influence on the Browser Widget.

Still doesn´t working for 4.23 :frowning: