Web browser ui widget doesn't run

I have been playing around with the web browser widget and while it works in the editor testing, it prevents any project it is in from building/launching.

My reproducible steps:

  • create a new project from blueprint template (i.e 3rd person template)

  • add the web browser plugin from the plugins menu

  • create a blueprint ui widget that only has a web browser box in it

  • have gamemode add the ui widget to the viewport

  • press launch button (or build for windows), it will build but open to a black screen and a fatal error prompt.

I understand it is experimental but it should be build able I would think.

Can anyone confirm that they can actually run with this widget? What might I be doing wrong?

Hello Smith389238,

I was able to reproduce this issue on our end. I have written up a report ( UE-19350) and I have submitted it to the developers for further consideration. I will provide updates with any pertinent information as it becomes available. Thank you for your time and information.

Make it a great day

Thanks Rudy, I appreciate you looking into it. It is good to know you see it as well. I was contemplating reinstalling ue4 to try to fix some setup/config problem.

I can only hope it is something that has a simple fix, and that it can make it into a future version. Given how useful it is to see any webpage, and how nice the widget is to use in blueprints, it would be a shame for it never to be used by any developer due to this build problem

Hi Rudy any updates on this issue? I can’t run my build either. Didn’t test this in 4.9 yet though.


Hello tomdelerue,

I went ahead and double checked on this issue for you. This issue has not had its status updated to fixed as of yet. I will be sure to bump up the community interest for you.

Make it a great day

Hi Rudy any updates on this issue?

Hello ,

After taking a look at the report I found that this issue’s status has not been updated to fixed as of yet, however I will be sure to bump up the community interest for this issue. Thank you for your interest in this report.

Make it a great day

I’ve just come across this issue too in 4.9.2. Had a quick look at the release notes for 4.10 but I couldn’t see any mention of a fix yet, any news?

Just found out that \Engine\Binaries\ThirdParty\CEF3 is missing from the packaged project, I copied the folder into my packaged project ( \WindowsNoEditor\Engine\Binaries\ThirdParty ) and the web browser worked.

Hope that helps,


This doesn’t work on an unpackaged/built project - and same crashing that is exhibited above (4.10 version)

have tried in a blank C++ and blueprint only project and still crashing.

Is there somewhere to copy the CEF3 folder to for an unbuilt project?

Hello walldiv,

The above issue deals specifically with the packaging issue that is being experienced. If you are experiencing a crash within the editor this may be a separate issue. Could you create a new thread (for tracking purposes) with answers to the questions below and provide a link in a reply to this thread? After that I will be able to assist you further.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints/widgets that may be involved?

I tried to package my project in MAC OS X EI Capitan.

In Project, I had only enable WebBrowser Widget from Plugin and set build configuration to ‘Shipping’. But failed to package.

I also tried ‘Development’, But got same errors.

It shows below logs.

link text

Hello ,

EDIT: Removed answer due to incorrect information.

After looking into the issue further I was able to find that this issue has not yet been resolved.

Make it a great day

Thanks a lot.

Worked for me. Though just tested for 64bit dev build.

I have the same issue, crashing on shipping packaged build.

Hi Rudy,
Any updates on the issue (UE-19350) regarding Web Browser UI widget failure when packaging project?

Kind regards

Hello SBK3d,

I have provided a link to the public tracker. Please feel free to use the link provided for future updates.

Make it a great day

Hi Rudy,
Thanks for quick reply. I checked your link, sorry if it’s obvious but is the status of that link that the issue cannot be reproduced?
I saw Tim Hobson’s answer on the community ref with a possible fix with 4.11?

Just FYI, I used v. 4.14.3 and  4.15.1 to try package.

Also got the tip to use setting “Compressed coocked package”?

Cannot reproduce means that the issue could not be reproduced any longer in the latest build (4.11 at the time) with the reproduction steps provided in the report. Meaning that the issue was no longer occurring. I hope that this information helps.

Make it a great day