Weapon clipping in to objects

Hello, I, have an axe and It clips into the wall, how can I make it collide with the object or just be on top of it and do not penetrate it? Any solution is helpful. Thanks
here is a screenshot:


For something simple, add collision to the head of the pickaxe and push it into the player/side on contact.

Also, check this post out.

The YT video shows how to handle this in an elegant way. There’s the detailed descriptions in the comments.

ok, I already have collision on the axe so that is not the issue, after 5 hours trying different things I found out the answer. I tried a lot of things in the post you recommended and there was one comment that open my mind a bit.
The guy had the idea of making the FirstPerson Camera Smaller, I tried it out and gave me a strange result, but did something. After that, I understood that there was no issue with the collision. It was a camera issue. I guess It is a clipping plane issue on that specific camera.
As a Test, I move the camera a lot backwards and it fixed the clipping issue, but gave my character a strange movement and turn. Then I understood it. When u make the camera smaller (in my case 0.5 worked) It makes everything feel farther away and that fix the clipping. I also moved a tiny bit back and done. looks great now. Thanks for the help with the link Everyone! (funny name hehe, I like it).

Hm, making the camera smaller. I want to say I’ve heard this before but not 100% sure.

I wonder if this has the same effect as setting near clipping plane - this normally controls how close to the player stuff gets clipped. Default is sitting at 30.

Anyway, glad to hear you managed to sort it out!