Download

Ways to mitigate visibility popping

I have a randomly generated level and I’m noticing some really bad popping of walls as my character moves around in the level. I tried making sure the static meshes are marked “Stationary”.

I know it’s due to occlusion culling queries. Is there some way to force unreal to do a precomputed visibility pass after generating a random level at runtime?

You can increase the bounds scales of any meshes that you spawn to stop them from being culled. But keep in mind this correctable issue I ran into when doing so.

https://youtu.be/6WtE3CoFMXU?t=1932

Oh nice, I was actually thinking about trying some of these bounds scaling options but wasn’t sure if this was the best way.

And actually further ahead he talks about HZBOcclusion which I’ll try first. I think I can be OK with rare popping with this on rather than the guranteed and constant popping I get with it off.

I already know that since our levels will be procedurally generated we will have slightly worse performance due to not being able to bake a lot of things.