Download

Water shader on Mobile starts skipping frames.

Hi there,

After about 5 minutes of playing on a iPhone the water material I have created begins to skip frames very badly. It starts off nice and smooth though. The frame rate to the scene is averaging 30FPS though. So I am not sure what to look at to resolve this issue. Does anyone have any suggestions or help to offer?

Thanks

Could you post screen shots of the material set-up?

Hi Wolfen, it’s probably precision issues (defaults to half); make sure you enable the Period on the Time node in the material editor so it runs at full precision.

Seems this is missing from the docs, I’ll add it.

This is a little difficult. I made most of the shader into functions to clean it up. The most used function is a custom panner and scaler using the absolute world position.

I hope I made the image large enough to read. I can’t get it on the site for some reason so here is a link.

http://i.imgur.com/XQpWsG1.png

Hi,

I am not sure where this is. I do not see it on the Time node at all. Just the pause option. We are still using 4.6

You’ll have to upgrade to 4.7 to get that option.

Ahh didn’t catch that. Thanks for pointing it out. =)