Water plugin not forming around landscape properly

These rock formations, I made using the landscape mode, have noticeable gaps between them and the ocean on the sides that face away from the WaterBodyOcean origin. Sculpting the landscape to fill in the gap does not work. Upon reloading the WaterBodyOcean, new gaps form. What can be done about this?

Hey there @tofeelpain! Welcome to the community! Assuming the water is using edit layers and affect landscape, the water’s edge is actually determined by this curve under your water body ocean’s curve settings:

image

Adjusting this curve can help you get a specific angle. Alternatively if that doesn’t work, you could also bring in the main curve of the ocean and change the blend mode to additive:

image

this will allow your ocean floor to remain malleable and able to sculpt, but has drawbacks of it’s own.

1 Like

Thank you for your help. While your answer didn’t have the exact solution, it did point me in the right direction. The Channel Edge Offset, Channel Depth, and Curve Ramp Width settings, under the Elevation Curve Asset you first pointed out, were all set to way higher numbers than they needed to be for me. I set them as low as possible and all my gaps disappeared.