Water Plugin Issues with World Composition

Updated to from 4.24 to 4.26 for the Water Plugin, but now I discover that it’s still very buggy.

I have a large landscape with 36 tiles (2017 res). It’s supposedly 30km.^2.

When I drop a lake onto the level (either the Persistent level or a Sub-Level), artifacts appear. These are deformations (craters, hills) in the landscape, outside of the lake. These deformations shift and resize as the lake spline is adjusted or is moved.

I tried adding more spline points and adjusting control points, but none of that had any effect.

Sculpting the deformations didn’t work either – at least not until the lake was deleted. Then the sculpting did take effect.

Anyone seen this? Any workarounds?

Maybe a project originally created as 4.26 would work better?



The water is there, it’s just under the landscape. But raising or lowering the spline doesn’t work. I can’t get the water to appear properly.

Hi faced the same problem. Helped to turn off Blur Shape in WaterBody details.

I gave up on this. I might eventually test your solution. I’ll give you the credit. Glad it worked for you. Thanks!

Having the same problem, is there a solution?