Water Planes and Unreal 4.9


Currently, the “Water Planes” pack that’s available for free in the Learn section is not able to be imported into any 4.9 projects.

When migrating the content through a 4.8 project, it looks much worse visually, even has some weird gaps from time to time in the moving texture. It also appears almost completely white when seen from a distance.

Is it possible to fix this? Or will the pack be upgraded to 4.9 in the near future?

Hi Rhidor,

It has yet to be updated for 4.9, however, there should be no issue with downloading and adding to a 4.9 project.

I did this earlier today doing a test for another question, and opening each map there were no errors thrown or seen for that matter.

To do this, you can click the Add To Project. It will open a new window with compatible 4.8/4.7 projects (depending on which version you’ve downloaded). Since you want to add this to a 4.9 project you can click the check box for show all projects and select the 4.9 project you want to add the Water Planes to.

Once added you can have a look in your project and open each map with the water included.

In your attached image above, you should compare the World Settings options and Sky Light options between your map and the ones included with the Water Planes. This looks like something in that area and not actually with the material or anything with the content that is included with the Water Planes.

I hope this helps.


I’m not sure if the maps will load as I’d like to use the water planes for my own project.

But thanks for the tip on how to import. Migrating is probably not the easiest way to do it.

I also kind of guessed it might be a SkyLight issue, as the water seems to be lit in a weird way. I’ll check the other maps SkyLight settings and post an update if it worked correctly.

After checking the “Ocean” testmap included in the package, I found that the map did not even have a “SkyLight”. Not sure what to change now.

It might also be important to know that I used the only mesh from the package and not the blueprint, as the latter can’t be rescaled. Both, however, look the same.

What can I do?

Not sure what you’re setting up differently. When I use a default scene with the engine scalability set to EPIC for everything my scene looks like I would expect it to.

As for the Blueprint that can be rescaled. It just cannot be by using the Scale mode tool. You will need to adjust the parameters in the Details panel for Water Scale X and Water Scale Y which are defaulted at 50.

There are plenty of other parameters exposed here that you can use to tweak as well.