Download

Water issue with 360 render

Hello everyone,

I have been trying to record 360 video Stereo Pano content. However, everything works fine, except the water where I am having the strange issues.
I am thinking it is because the refraction, but when I disable it, the same problem appears.

Here is the picture, please let me know if anyone know what is happening here.

I actually ran into the same exact issue and worked around it, but it ended up being 2-3 little things and I can’t remember exactly what I did. The issue is something to do with the camera being perfectly aligned on axes for the side captures which causes issues with the way some of the vector transforms are done.

Of course I look at the material where I had this problem and I didn’t save it with the fixes. I made them, captured the cubemap, and forgot about the changes. Doh! I will see if I can repro it and remember exactly what the fix was. I want to say I just added a fudge factor to the camera vector…

edit are you doing anything with scene texture? Any view transforms? I narrowed my problem down to a View-World transform.

Hi Ryan! Thanks for the answer! I have tried different things with the material setup, but like I said, I came to nothing. It is always the same problem, so I suppose there is a problem with something else. And just to make a quick note, I am using water materials from the Water Planes on the Learn tab. Fudge factor to the camera vector?
I am using cube render targets and there are four of them at every direction, check the video here: https://youtu.be/b6Ca8IMiuuY

Why do you need 4 of them if its stereo pano… wouldn’t 2 cubemaps suffice? Each one would be a 360 per view so not sure why you’d need more.

are you using any specific version of the waterplanes material?

I loaded up the translucent_waterplanes example, placed a SceneCaptureCube, and did not see any problems:

cube.JPG

There are 4 of them, 2 of them for the regular pano, and two other are for top pano if I am correct. So, only two of them are used, depending on what pano setting you want.

It seems translucent water show less artifacts. However, lake water is causing it to be a bit more visible and that is the one I am using. When I add regular scene capture cube there are no issues, there is something happening with the actual blueprint from the video I have downloaded it seems. Any chance you could grab it and check what is happening there, I really don’t know where to go. Thanks!

Here is the link: https://drive.google.com/file/d/0B5999tVBIaIwOHBfSE9wdW56Unc/view

what exactly is the ‘top pano’? Guess I am not sure how you are actually using it. What are the different settings if you don’t mind me asking?

I think your problem is screen space reflections if this is opaque water. Try expanding the extra options on the scenecapturecube actor, expand showflags, expand lighting features, disable SSR.

I usually do not have time to download projects to try them since I am not a support person by job title. I just try to browse the forums and find quick ways to help in between my other tasks. If somebody has been having no luck for a long time, or if its a very specific issue that I will have extra insight into, I might do it. You will usually have better luck getting people to repro using your project on the answerhub, just incase it comes up again. Requests on the forums do not get tracked which makes that kind of effort more tricky.

Hi Ryan.

Thanks for the help, I really appreciate it.
I have tried with Allars stereoscopic plugin and it works like a charm with the water and everything else so far.
I just had a little seam issues on the water and that was caused by SSR. I am hoping it will work with planar reflection, will give it a test later today.

Thanks again for the help!