Download

Water and glass shaders not rendering correctly in 4.22 during runtime

This is a bit of a strange one for me, but I migrated a project I was working on from 4.21 to 4.22. I’ve done so by selecting the main level map and just migrating it since it contained everything I need.

When I opened up the project in 4.22 and created a runtime build, I noticed the water and glass shaders were off and not rendering correctly. It’s as if it didn’t reflect correctly or even being lit correctly. In the editor viewport, it appears to be fine, as well as in the selected viewport preview mode. However, I can see the issue when I do standalone game mode to preview it, so that’s what I’ve been using to try to diagnose.

Here is how my project is set up:

  • One main level map, with sub-levels added in. Some are always loaded, while others are loaded via blueprint.
  • Lighting is movable for both skylight and directional with distance field enabled.
  • I’m using using the sky from here: https://www.unrealengine.com/marketplace/en-US/slug/ultra-dynamic-sky
  • Support Compute Skincache is enabled in project settings so I can create LODs for Anima 3d people crowd sim.

Here’s what I’ve tried:

  • Saving a copy of the main level and slowly deleting bits and pieces of geometry, lights, volumes, fog, etc to see if any of them is the culprit. Even the sky too.
  • Creating a new map with just bare essentials of lights, water plane and some geometry to help troubleshoot or find something to reproduce the issue.
  • Rebuilding reflection capture probes, and then deleting them all to test.
  • Removing sky and all lights and adding them back in

What I did find so far is that if I change the skylight and directional light from movable to stationary, then it will render correctly in the standalone preview. However, if I change it back again, the issues returns as well. I attached a screenshot to illustrate. It includes both the viewport and standalone preview window, each both rendering the water differently (the one in the viewport is the desired result)

Any help would be greatly appreciated!

What is set at your project settings for Default RHI ?

Everything was left as default in the Targeted RHI section.

  • DirectX 11 & 12
  • DirectX 10
  • Default RHI - Default

Doesn’t leaving Default RHI = DirectX12 fix this?

Unfortunately it doesn’t seem to do anything when I change it.

It’s bug, in 4.22 don’t work translucents materials (Lighting Mode: Surface TranslucencyVolume + ForwardShading).

Yeah I figured it seemed like some sort of bug maybe. I can get it to work in a brand new scene I think, but generally seems hit or miss. Though I’m hoping it’s a bug and can be resolved eventually since I can’t find anything in my scene that’s causing it.