Washed out Material Color RGB?

Hey guys,

I am working on a mobile game for android and I have some problems with my materials.
I have a picture of a character and I made it in Blender (2D).
I looked up the color codes of the image and use it in my material but the colors seem a bit washed out?

I think it has something to do with the RGB because if I put the image in unreal and turn off ‘sRGB’, the image looks the same as mine materials.
How can I make sure that my materials look the same as my picture with sRGB on?

My game is a 2D endless runner for Android that does not need lighting, in the pictures you can see my settings for the materials.

Hello Colder347,

Make sure you use the correct color input, if you created the texture in a linear color space, use the linear color input, if you instead used the sRGB color space use the respective input instead (the two bottom input fields).

Hope that helps. Just a friendly advise: don’t use Preview Versions for commercial/public Products, unless you’re certain you need the extra functionality it provides and you’re certain that the Preview Version or updates to it do not break any functionality, as these versions aren’t supported, guaranteed to be stable nor are they guaranteed to not break any previous implemented functionality.



One thing to also take note of: When making / baking textures in a 3D- or a paint program, make sure that you’re exporting in an appropriate colour space (Linear, XYZ, sRGB etc)

Thank you for your answer, unfortunately, this did not help me any further.
I tried both color inputs but I don’t get the same colors as the picture.

I even used the eye-dropper from unreal on the original image and I also get the same, washed-out results.

Thanks for your advice on the engine version, I have looked at other versions and everything comes out much better, it seems that everything in 4.25 is lighter than it should be.

I will leave the question open for a while because it may be a certain setting, but when the preview phase is over and the problem is solved, I mark this answer as a solution.

Sounds like an overall gamma issue, but this reminds me of an odd bug I had. My game’s gbuffer (or some other buffer) was set to float and that made everything washed out. It’s a reach, but tinker with your project settings and tell me if that fixes it.

Yeah, I’m going to do that. I now have created a new project in 4.25 to see if it is due to my settings but unfortunately, also in a clean created project I get this problem. I’ll keep you informed.

Is the color washed out only in the preview window of the material editor? How does it appear in the main editor viewport?

Certain settings in the post process volume can result in washed out color appearance. Check that. What are the Lightmass settings (in World Settings)? Is global illumination at default settings in the PPV, or are those changed?

Hi presto423, it is washed out in the main editor viewport.

I don’t use a post process volume, do you think this is necessary for a mobile game?

Didn’t change Lightmass settings, I see in the descriptions that some can use a lot of memory / performance, I think that in my case they can be set much lower but I do not have much experience with this so I have to look at this first.

Do you mean global illumination in project settings? In project settings ‘Screen space Global Illumination (Beta)’ is False.

Did you ever resolve this? I’m having the same trouble and it’s driving me mad.

Hi @EnergyLad ,

Saving my Basecolor textures in 8 bits instead of 16 bits, made things work for me. Hope that might help you somehow.

Yes—I was using 8-bits per channel for the original image, though Photoshop was helpfully exporting a 24-bit image.

Screen Shot 2022-03-07 at 11.14.08 AM

In the export window, I had to specifically request a “Smaller File (8-bit)” to get what I thought I already had.

Thanks so much for the confirmation—for anyone else: this worked for me. Good luck!

1 Like

look at this