Download

Was there ever a fix for nav invokers not working in packaged projects?

I have tried in 4.21.2 and 4.22 . It works normally in editor , but will not work in a packaged project. Does not work in stand alone game either.

this is like completely unusable and broken. it works perfect in the editor , but in standalone or packaged it is completely not working . I noticed the in project settings / nav mesh , the setting "can be main nav data " has to be checked for it to even work in editor. So I have it checked , but when I close the project and reopen it , it is unchecked. So it unchecks itself for some reason.

Would you file a bug reportdetailing your issues? Thanks!

I was getting on that , though with further testing I found that it works in 4.19 and 4.20. this may have been caused by a switch to 4.21 and 4.22. One thing I noticed is that setting mentioned above , " can be main nav data" , is always greyed out in a working situation. where it cannot be changed. When it don’t work , that checkbox is not greyed out , and can be shut off. where when a project was closed , it always shuts that setting off automatically, when re opened. And has to be turned back on to work at all , even in the editor.

I needed some foliage because it was optimized , but that asset only could use 4.21 and up. So I switched unreal version to 4.21 , and I think that may be what caused it.

any news on a fix? eta?

Was there a bug reported with this? It’s difficult to track internally if not. I’d be happy to follow up on it.

This bug still exists in 4.21, and possible 4.22

I’m still suffering from this issue any fixes yet?

Version 4.24.3. Im getting the exact same problem. This is critical, none of my enemies can move so combat is impossible. I cant find any resources or threads about this problem except this one.

Yep I tried again to up my project to 4.22 , but nav invokers does not work.

So i submitted a bug report , though I don’t really have a sample project , as mine is already well along , but worked in 4.20 but not now since moving up to 4.22.

Did you move your project up from an earlier version ? Or did you set it up straight from the beginning in 4.24?

It don’t even work in the editor for me now.


This was inside the DefaultEngine.ini file in my project folder. It was false even though in the project it was true. For some reason it wasn’t changing to true but it was showing true in the project but when I changed it to True manually in the .ini file it got fixed.

I know its a little late but I hope this help because it drove me mad when I was trying to find out why it wasn’t working.

I am having the same thing, My project was moved from a previous engine version, Navbound is in PLevel, invokers just don’t work, I have tried everything, any thoughts on this!

Anyone managed to find a solution for this?

Not really but try raising the "Cell Height " number , i can’t recall if that was what helped , i think i raised it to 75.

Hey! I just spent hours trying to figure out why my nav mesh isn’t working anymore in the packaged game, and I don’t know if it’s a coincidence or not but this one did it for me!

It’s such a strange behavior, because the nav mesh works fine, then it randomly stops working. I then try everything, from redoing the volumes, to moving them from persistent level to my geometry level, I tried to build them only in one level, and not the other. This feature is VERY broken in Unreal 4, and I have wasted countless hours trying to fix this. In fact, I think I spent more time in the past few weeks dealing with random problems like this, than actually creating what I want. Unreal needs a serious deep cleaning. …

lol, I spoke too soon, after doing a bit more work on the environment, the nav data is not loaded in the packaged game anymore…

Coulpe of years later, navmesh still doesn’t work in packaged games