Warm up time does nothing with GPU Particles in UE4.4.3

Hello everyone.

Just as the title says. With the previous version I used, 4.2.1, I could enable warm up time to GPU particles and it worked fine. But in the current version, 4.4.3, that doesn’t work anymore. When I hit play or simulate, particles start playing again from the beginning. With normal particles it works fine.

Does anyone know the reason of this? Thanks.

Hey PacoChan -

Can you share your Particle Setup? I am not able to reproduce this issue in house.

Thank You

Eric Ketchum

Thanks for your answer.

It happens even with the most basic setup:

  • I create a new blank project with no starter content.
  • I create a new Particle System.
  • I drag it to the scene.
  • I open cascade and set Type Data to GPU Sprites.
  • I set Lifetime to a Constant 10.
  • I set Warmup time to 5.
  • And I set fixed bounds.
  • When I hit Simulate or Play, particles start from the beginning, like if I had zero Warmup time.
  • If I remove the GPU Sprites module, it all works ok.

I’ve done some more testing:

  • If I package the project, it works as expected, both in Development and Release configurations, so it seems that it happens only in the editor.
  • Sometimes it’s happening in UE4.2.1 version too.
  • I recently changed of OS. Before I used Windows 7 x64 and now I use Windows 8.1 x64.
  • In Windows 7 I never had this problem with UE4.2.1. I’m not sure with UE4.4.3.
  • Since I upgraded to Windows 8.1, I had some graphic issues due to nVidia graphics drivers (reflections flickering all over the place). I updated the drivers from version 340 to the last version, 344, and it solved the problem.
  • Maybe this GPU particle issue is related with my OS, drivers or something like that?

This is all the info I can think of. Thanks for yout attention :slight_smile:

Hey PacoChan -

I created a quick test that is working correctly on my CPU and I want to make sure that it is working for you. Unzip this project to a new folder and double click the *.Uproject file. PIE and let me know how many times the particles cycle before disappearing.link text

Thank You

Eric Ketchum

Hi again, Eric.

The particle system cycles two times and then disappears.

So Warm Up Times are working. If you go into the Particles emitter and change the warm up time to 0 it will cycle 3 times. How are you trying to use the warm up timer specifically, there is probably a setup issue that is causing you problems.

Let me know -

Eric Ketchum

Hi again.

I’ve modified your scene. I added to the right of your particle system a basic GPU Particle system like the one I mentioned before. And to the left, the exact same particle system but with no gpu particles.

I also send you two screenshots of how the particles behave in my PC:

This is in the editor, just after hitting Play. GPU Particles are not working as expected:

This is in a packaged build, just after executing AH_GPUTest.exe. GPU Particles are working as expected, just like the ones in the left:

As you see, there’s something wrong here.

I send you back the modified scene:[link text][3]


Sky lives by it’s own life as well.
But warmup working inside Cascade (reset by ‘space’) and release, so it’s fine at least.

Hey PacoChan -

Thank You for the clarification it was the looping that got me. I have good news, the fix is already in place and should be pushed out with the next release version of the engine, 4.5.

Again Thank You

Eric Ketchum