Download

Wall edges and room corners showing bright borders

I am not sure why the borders of all these walls are bright. Shouldn’t the room be dark? The edges are close but not overlapping. When they overlap they start flickering and I get warnings/errors when building. So I don’t think overlapping is a good idea but I can’t figure out how to make a dark room. In the examples, the rooms are built the same way but those are dark where as mine doesn’t turn out to be dark.

Thanks

Here are the pictures of the room from the inside and outside:
c911b6c6ce75e0d21f1fd8f675845fe4bec34913.png
Outside Room.PNG

Maybe this thread is not in the correct section? Can somebody please move it to the correct section?

Thanks.

Did you try increasing lightmap resolution?

This is what it looks like with a Lightmap resolution of 1024, do I need to go higher?

b66817e1fbfd1c6641f80fa482996b59feaf4627.png

Just to give more background to the issue. I am using the Walls and Floor from the starter content and placing these objects similar to how the “Lighting Quick-start Tutorial” states I should place these. Thanks.

This is due to light bleed.

2 things that have caused this for me.

  1. The walls CANNOT be single polys. Your room must be “encased” inside of water-tight geometry. Try building a box around that room of cubes for each wall. that will stop the light bleed and correct the interior light maps.
  2. Bad UVS for the mesh. Anywhere that you have a hard angle (like where the wall meets the floor), you must split the UV seam.

Increasing the light map resolution might hide this a little, but it wont correct it, and it will make your light maps really really inaccurate until you fix the bleed.

And using the option “Treat as double sided geometry” will not fix it either.

You must encase it completely with blocking geometry.