Vulkan Mobile - How to get rid of Aliasing

Hi Epic Games, I made an app for Vulkan and Cardboard on a Samsung S7 devices. It’s working pretty well. But I got a big aliasing effect on mesh edges. And I can’t get rid of it, even in UE Editor in High End Mobile preview [Vulkan] I got this effect ! Here is a capture of the scene on the UE Editor !
I tried, Temporal AA, MSAA and FXAA, does not change my problem (the texture AA is working well, so I know that I have the effect). I tried to change the scale factors, but without success.

I someone have any tips !

Have a nice day !

It’s maybe my screen resolution by the way, but I have no clue how to change it properly !

Resolution scale

Thanks but I’m already in Full Scalability Settings, I don’t know if it’s Vulkan which does this effect !
Because if I make a preview in standard SM5 Shaders, everything is okay !

So, in the preview editor, when I enter r.MobileMSAA 4, the render look really nice, but on phone (Samsung Galaxy S7) the application crash !

I have the same problem. I’ve converted my Gear VR project to cardboard and it works fine but the aliasing is tremendous. I have tried all the different AA and I’ve tried to change the r.MobileContentScaleFactor and the r.MobileOnChipMSAA in device profiles and nothing has changed

With UE4.15 under Engine Rendering section in project settings you can now find mobile MSAA option. Enabling it I have fixed my cardboards aliasing problem.

Thanks for your answer. I tried it with 4.15 and yes it works fine, but finally we abandonned the cardboard Idea. Because it’s a bit laggy and you become sick easilly compared to the Gear VR. (Even if the game have a good framerate you still have a kind of ghosting on the edge of the objects when you move your head (even in the cardboard demo by Google !)

hi, did you found any other solution? my Galaxy Tab A is also crashing if i kept to 8xMSAA please let me know if you have any solution.Now i am getting like this