Download

Vulkan and ES3.1 UE 4.24.3 Output Issue

I’m working on a project intended for Oculus Quest. I’m building it on UE 4.24.3. The Mobile Preview Play In Editor is identical to the output I see when I deploy to my Quest: an all black output. I’ve tried previewing/testing using Vulkan and ES3.1 and don’t see a difference in the outcome.

​<pic 01>

https://forums.unrealengine.com/core/image/gif;base64

The short gist of what I’m doing: I’ve modified the pawn from the VR template and added a directional light that moves with the player.

​<pic 02>

https://forums.unrealengine.com/core/image/gif;base64

When I play/test via Oculus Link, it appears exactly as the non-mobile previews (not overly surprising) and non-VR play tests.

<pic 03>

https://forums.unrealengine.com/core/image/gif;base64

However, when I play in Vulkan Preview or ES3.1 Preview mode, I get the black output.

It will display debug text on top of the black output both for PIE and on deployed Quest project.

<pic 04>

https://forums.unrealengine.com/core/image/gif;base64

The editor viewport (not playing) shows what I expect and believable differences with the active Android Mobile preview on or off.

https://forums.unrealengine.com/core/image/gif;base64

<pic 05a>
<pic 05b>

https://forums.unrealengine.com/core/image/gif;base64

Oddly, whenever I “eject” and select the VRPawn from World Outliner, the camera preview displays how I expect.

<pic 06>

https://forums.unrealengine.com/core/image/gif;base64

The issue seems related to lighting, but I’m not very confident in that assessment. Based on my reading, the Mobile VR (Quest) target should be able to handle a single dynamic directional light. I’ve tried to neuter this light as much as possible from a perf perspective. I’ve tried primitive solutions like migrating to a new project with no success. I’m really hoping I’ve overlooked something simple and/or obvious. Any feedback is appreciated!

i would guess it had to do with view distance culling. how far away is that planet?