VR-Template - on level load, teleport function is broken

Hi! So, as per the title, I have a 3 seperate VR levels using the VR motion controller template(for Vive) which are essentially clones of one another but with slightly different content. The project is essentially a model viewer in an ‘endless studio’ type environment. I have set up a UMG menu widget and actor to select the desired level and load it. All functionality works fine (teleport, trigger animations, material change etc), however, as soon as i use the load level function in my menu and enter one of the other levels, the teleport function is broken. (see attached picture) I have noticed that I am spawning in the exact same position as when i triggered the ‘load level’ function rather that the spawn position of the VR pawn. Would this make a difference? I have not changed the navmesh or the floor mesh in any of the levels - they are all identical.

Its possible that you don’t have the teleport area in the level, in that case check the VR template blank project, or the teleport area is below the floor.

Thanks! I retraced my steps and found a deleted navigational element! All fixed now! :slight_smile:

I have the same problem, but can’t figure it out. Do you have any idea (after 3 years :slight_smile: ?

Having the same issue. Works fine on level one and works fine on level two, if I launch to HMD from level two BUT if I start on level 1 and do a OPEN LEVEL to level two I get that same broken teleport like in the first image.

Any specific ideas?

Hi all

I’m a relative novice, and I too am having exactly the same problem as josephoracle. Each level works fine if I launch it - which suggests no problem with the navmesh. It is only after I move to a new level (via Open Level in a blueprint) that the teleport breaks. It really feels like there is something very obvious and straight-forward that I am just missing.

(I’m using Oculus Quest, not Vive)

Any idea?

I ran into the same issue. For me it was the navmesh volume not properly setup. If you hit P in the editor or go to show/navigation you should see green everywhere you want to teleport. If not then it could be the collisions for the objects or something in the navmesh settings maybe. I didn’t want to create collisions for my geometry so i just dropped in boxes and set them to be invisible and it worked for me. Hopefully this helps.

Try checking “Force Rebuild” in your “RecastNavMesh” details panel under “runtime”

1 Like

I’m having something pretty similar. In my case, buttons work but the teleport doesn’t work properly even the nav mesh bounds applied correctly. When launched the level, the teleport works fine, but when I enter the level from another level, it doesn’t work, the linetrace also doesn’t work when the level change happens. I even removed all collisions from everything just in case, yet the problem persists, don’t know anymore what to do. Someone help me plzz

Im sincerely flabbergasted that Epic still insists on using these clunky, fiddly, buggy-as-hell navmeshes for something as critical as VR locomotion. Wrestling navmeshes is a headache you simply dont need.

Break the habit. Use a method that’s flexible, cheap, modular, and doesnt use a component thats better suited to AI pathing:

After 5 years still having a problem any help ? It’s not a collision issue or nav mesh issue.

I am going through this problem too. It was working fine once but the it went back to not working again. Does anyone have any ideas?