VR - Stereo On on BeginPlay sets resolution to 720p in packaged build

So, I’m launching packaged build, it checks for -VR flag in command-line, and if the flag is present, GameMode calls Stereo On on BeginPlay, but the resulting resolution is 720p, not anywhere near the Vive native resolution. But there’s a catch - if I run Stereo On manually via console, it works normally, like it should.

How do I make a build that doesn’t require user fumbling with console?

The one thing that helped in my own project was simply to load a different level, and suddenly the resolution was correct.
So, as a game start map, use a completely empty one and in the Level Blueprint to a “Open Level” node directly on BeginPlay with your real first level as a parameter.


That worked, thanks!