VR Shipping Build is blurry and slow

So I have a pretty weird problem:

My shipping builds are blurry (like the UI widgets are barely readable, even though they’re big and perfectly clear when debugging)

And the game is running slower or something, maybe the physics. It’s not slow in itself, the framerate is fine, but objects are moving slower than in the editor

This is in VR (HTC Vive) and I’m running my game through SteamVR.

Hi Malharhak, i think i have the same kind of problem as you. And only with 4.12 not with precedent version. I have described my issue there : Problem with HTC vive and 4.12, build are blurry but fine in editor and 4.11 ? - XR Development - Unreal Engine Forums

Is it a similar problem ? And did you find a solution ?

I don’t have much time, I’ll edit this answer with more details soon, but in a nutshell:

  • on your beginPlay, run some console commands via blueprint
  • r.setResolution, to the resolution of the Vive (you can find that on the web probablym not sure the exact command)
  • r.ScreenPercentage to up to 200. 150 is okay usually, but the default is a bit blurry.

The slowness in my game was due to me using physics impulse every frame, which are meant to be used once, si it made my game framerate dependent. Avoid that.

Also type “stat fps” in the console to see your FPS. If you don’t have a constant 89/90, optimize. Start by disabling shadows, and removing lights that you don’t really need, use static meshes as much as possible, etc.

Posted an answer with the solution :slight_smile:

Thanks a lot for your very fast answer !
it’s work very well for me with the r.screenpercentage command .
Many Thanks again !!

I tried this. It’s getting better, but it’s still not as good as the image quality I get in the editor

Have you tried removing shadows? shadows are ususally too expensive for VR, and in most cases you can do without them or use some tricks.

Ok, much better with higher screen percentage to ~150 set via LevelBluePrint. I also increased PostProcessAAQuality to 6.
But now the framerate goes down (~45) …

Many thanx


Your answer does not provide the solution. I add some screenshots to show the effect on my side.

I tried a lot but I can’t get it to look like in the editor.

For everyone else that finds this as a first result in google. Nothing helped for me, not screenpercentage or anything.

Then i noticed something funny: As soon as you do a “Open Level” command, the resolution suddenly is back to normal.

So what i did as a workaround is to have a reload of the current level immediately on beginplay (and saving the boolean flag for “alreadyLoaded” in the gameinstance, so i dont have endless reloading).

So, just try to have a binding for a button and do a “Open Level” with the current map.