Download

VR Project Issue: Skylight Forcing A Sort of Terrible Auto-Exposure Onto The Level

Hi everyone,

I have a problem with a project that I’m stumped on. I have a scene I’m working on for a VR project, and whenever I look in the direction of my moonlight, which is a stationary light and the only dynamic shadow-casting light in the scene (with almost all meshes static and lights baked), if I have a skylight on (SLS captured scene), it seems to force a kind of mild auto-exposure very specifically on the volumetric lighting/fog which is absolutely glaring in VR.

  • There is only one light casting dynamic shadows in the scene, the moon, which whether stationary or dynamic causes this issue, and with the exception of very few props every mesh is static, and lights are baked. Inside the house: not an issue. Outside it’s a glaring issue. It also seems to happen in another closed room that’s occluded the same way as the others for no readily apparent reason.
  • I do have volumetric fog and light shaft occlusion. Turning this off and on doesn’t seem to affect it, though.

The way it happens is really strange. You’re looking in a direction, everything is dark. You turn about 20 degrees… Everything dramatically lights up. In VR it is a GLARING problem. See my three pics. Super dark, super dark… bright! (That is, if my pics actually upload… I’m now getting an “invalid server response” uploading them here. Not frustrating at all.)

If I set my skylight to static this effect ends and doesn’t return… And taking the volumetric scattering intensity down to zero minimizes it greatly (but it’s still there! Just VERY mild!). So is this a weird bug, or should I just find an alternative global illumination solution? Or is this some aspect of lighting volumetric fog that doesn’t like to work with skylights, but only in very specific scenarios? The way it happens is even like auto-exposure or eye-adaption - if I flick it on and off by changing the skylight from static to stationary, it smoothly darkens and lightens with a smooth in-and-out, exactly the same way auto-exposure does it.

My attempts to stop this:

  • Auto exposure has always been off in the project settings, since the beginning of this project.
  • There is one Post Processing Volume at the moment, while I try to fix this. I’ve tried not using auto-exposure in it, as well as turning it on and setting the min/max to 1. No difference.Also tried this on the player camera, also no effect.
  • I have also tried an unbound PPV, no difference.
  • Eye adaptation is disabled in the “Show” menu. Happens anyway.
  • Playing with my lightshaft occlusion or fog controls seems to have no effect on this skylight auto-exposure it’s doing.
  • It is highly affected by the skylight’s volumetric scattering intensity, though removing the scattering altogether only decreases the issue, it doesn’t resolve it.

Is there some other solution to his? Is this some kind of skylight baking issue? It’s not a ruinous problem at this point - I can turn off scattering on the skylight, increase it’s brightness a bit more, keep it on stationary, bake the lights and it’s looking pretty good. However, I like the effect that it has on the fog when I have the scattering intensity at around 0.75 - it makes the view distance look a bit higher and there’s more contrast between the lit fog and the shadows of the trees. If I could have the skylight’s indirect scattering on 1 without the dimming/darkening I’d prefer it.