VR Preview working in UE4 But not in UE5

Hello Everyone,

Thanks in advance for the help.

I am not able to locate the VR Preview in UE5. Seems like it has been disabled or something.

Please Note - It’s working fine in UE4 Version.


Hey there @Nirlep_Id! Welcome back to the community! So the VR preview is polled just once when the project opens, so you need to have your headset and SteamVR active and connected before you open the project fully, otherwise that launch type stays locked.

What HMD are you using?

Thanks for your reply.
Yes, the headset and Steam Vr are connected.

Quest is connected in UE5 ( Screen Shot below)
I am using Oculus Quest 2

When I click on Quest 2 Launch it makes the apk package for the quest. But what I am looking for is a VR preview, not the package.

Thanks again for the help.

That is… odd. We’ll just run through a quick checklist, because in general the headset needs to have the oculus software and steamVR connected and registering the headset before you can launch Unreal. If you launch UE and then connect the headset it doesn’t register it for the play menu.

So first we launch the oculus software and connect the headset via airplay or cable and verify in the software it shows Connected and info about your headset (ignore that mine died right before I took this image):

Then, in headset or outright launch SteamVR and look for the viewport change in the HMD

Then finally you can launch the engine (if launched before this step it will not be there), click the 3 dots (ignore the platform dropdown) and you should see the VR preview lit again.

If after following all of that it still doesn’t recognize the device is connected, this might be an ecosystem issue.

Hello there,

Thanks for helping out on this. Really appreciate it.

I did the same as you mentioned.
I connected my oculus and Steam VR before launching the UE5. Still, it’s not showing the VR preview option.

The problem is, WIth the same settings I am able to see it on the ue4 version.

Is something turned off by default that we need to turn on in ue5?

Also, what do you mean by “ecosystem issue” Sorry could not understand that.

Thanks again.

Hello Again,

Currently, I am using the below option to run it.

It does play in steam after the packaging process. But Still not showing VR PREVIEW option under the platform tabs.

Thanks again.

I’ve been seeing recent reports of OpenXR sessions being destoyed on launch, and sometimes not making the connection with SteamVR. So this could be connected with those issues, which are suspected to be because of an oculus driver update (but we’re still getting info on that). Is it just grayed out under the modes tab here? (not under the platforms?)


It’s not under the Platforms.


Oh sorry about that! Got stuck on your verbiage, the preview portion isn’t what you were looking for but the build utilities itself. That “Quick Launch” menu inside of platforms is for quick building and not so much the preview. Are the android platform SDK’s set up and targeted correctly for UE5? The quest quick launch target could be missing in that case.

Reference thread:

Yes, SDK is set up correctly.
Please let me know if you want me to refer to any specific video for that.

Well regarding the reference thread you mentioned, My quest is attached to the unreal as you can see in my previous Screenshot and video, The only problem is VR PREVIEW is not there.


Hmm, if the SDK and root values are correct and it didn’t reappear after connecting them, it could be a bug. I haven’t been able to find any more information on the matter.

Hi all,

I don’t think it was explicitly mentioned in this thread: But the Oculus VR plugin is now disabled by default in 5.x, In Project Settings → Plugins try enabling ‘Oculus VR (deprecated)’

Also, make sure you’re running the Oculus App on your PC and are in Airlink/Wirelink on your Quest before starting UE. (Running SteamVR ontop of Oculus VR is not necessary for VR Preview)

1 Like