Download

VR Preview not available

Hi, im new to Unreal Engine.
Borrowed Oculus Quest 2 from a friend and tried vr template, but seems VR Preview are not available.

I’ve installed sdk,ndk, jdk, and even oculus link and dev hub, and been looking through various chanels from youtube for a solutions but none are work.
any suggestion?

Hi, some might missed in your case.

  1. How about installed Steam VR?
  2. Oculus Quest 2 need the “Oculus Link” which I think you have installed, but make sure the Set-Up is successful. And other thing is you need to Enable “Link” in your Quest device before open Unreal Editor.

FYI my open step in VR:

  1. Open Steam & Steam VR
  2. Open and put on Quest 2, then Plug the USB cable to connect with PC, then enable “Oculus Link” in your headset
  3. You should see you are entering “White World” in Quest
  4. Open the Unreal Editor now, and it should success

You don’t need SteamVR to use Oculus Quest 2 w. Oculus link. You need to make sure that the Oculus Runtime is installed and that you have Link enabled.

Before you start the unreal engine,
You have to have the headset on, click ALLOW data access on the in headset popup after you plug it into your computer (or connect with AIRLINK), if you don’t use AirLink connect via Oculus Link. Either way, once you’re loaded into the Oculus link (Rift) menu, you can THEN open your unreal project. If you do those things after the editor is already open the “VR preview” play button will stay gray until you restart the editor.

HI. thanks for reply

heres an update:

stuff i forgot to mention(my bad)

i use usb 3.0 type A to type C to link it
and i use laptop

i’ve access to Oculus Link and has enabled the run the “OpenXR Runtime”
but when i open desktop it’s just black screen, but then i tried add unreal editor through add desktop panels it also blank, BUT thanks to suggest open unreal editor in oculus the VR Review is available.

now… is it a connectivity issues with the desktop because of the cable?

i noticed it it’s not “grey”

thanks for point that out

I had to completely remove/delete my Oculus CV1 from Oculus Settings to get Quest 2 working properly in Unreal Engine (using Open XR settings). You may want to try this.