VR Preview Grayed Out

I apologize in advance if this is a super noob question. I can’t seem to get the DK2 to function consistently with UE4. Almost every time I run a project, the VR Preview in 4.7.6 is grayed out and unavailable. Here is some info on my machine:

Using Oculus Config Utility 1.7 (SDK v0.6.0.0)
Display Driver Version:
Positional Tracker Driver Version:

NVIDIA GeForce GTX 980
Intel(R) Xeon(R) CPU X5550 @ 2.67GHz Dual Quad Core
Windows 7 through Bootcamp on a 4,1 Mac Pro Tower
24GB 1066 RAM

HMD Firmware: 2.12

Connected to OVRService server.
I am currently in Direct mode, but have tried the Extended mode as well.

I don’t have any problems looking at the “Show Demo Scene,”(Through the Utility) However, looking at any of my custom projects or even some templates in UE4 has been completely hit or miss. I can’t seem to find a pattern to fix the issue, even if I run the utility before running the UE4 launcher. Same issue persists after a restart as well, because I heard the Oculus runtime crashes occasionally. GFX drivers are up to date as well. I’m kind of at a loss as to where to search for answers, so here I am.
I’ve noticed in other posts that people have had similar issues, but I feel like I’ve tried their solutions with little to no avail.
Does the plugin only work on projects created after the runtime was installed? The plugin appears to be enabled and working in UE4, even on older projects, but it still has a grayed out VR Preview.
Also, when I use standalone, it doesn’t send it to the oculus, instead, it blows up the image and makes it fullscreen, without actually increasing resolution.
If it helps, I also have 3 monitors. I’m not sure if that can cause problems or not, but again, sometimes I can get it to work.
Any thoughts on this would be greatly appreciated.
Thanks for your time.

The 2 issues I’ve run into are:

  1. restart the oculus service
  2. make sure the Rift is powered on and functional before you open the project. If it’s not operational before you open the project, the option will be greyed out.

Thank you very much @3dlight for your reply. I will give these a shot when I get home tonight.

Just to clarify, when you say restart the oculus service, are you saying close the utility, then restart it, or reboot the whole machine? or start/stop the oculus runtime?

I’ve always had the “Ready” signal from the utility before starting up the UE4 editor. When you say powered on and functional, do you mean that the light on the rift is orange or blue? It only appears to be blue if there is video pass through.

Since UE4 uses a native plugin for the rift, is it possible that the current runtime and SDK for the oculus is newer than what the UE4 plugin will allow? Still doesn’t explain why I can occasionally get it to work. So far it seems like 3 out of 10 times I’ll actually get it running, but I haven’t seen a pattern yet.

One last question, in your opinion, is it better to use direct or extended display mode for the rift, specifically for dev in UE4?

Thanks again for your time. I really appreciate the insight and help.

I was able to get the vr preview option in the play dropdown to work using these steps.

i restarted the service, and then had the device on when the engine loaded the level.

My VR preview is grayed out as well, it was working, my level started acting strange, glitching hard, and now the VR option is greyed out, when I try and use it on another level, VR works no problem. it just seems like the one I’m currently and needed it on. has this happened to anyone else, tried all the suggestions on here. none are working.