VR Preview disabled on DK2

VR Preview is greyed out. It has been disabled since at least 4.10. I’ve reinstalled the latest Oculus runtime and rebooted. I’ve also loaded the editor with the HMD connected and switched on. Neither action has helped.

If you’re using 4.11.1 it requires Oculus SDK 1.3 so you will need to install Oculus Home to use VR preview (Setup Your Oculus: Quest, Quest 2, Link, Rift S & Rift | Oculus - 844MB downloaded during install. Unreal editor will need to restart if you are switching runtimes). FYI DK2 is fully compatible with Oculus Home despite the warning message in-app, but if you want to use oculus share demos still, you will have to set up runtime switching (use google).

I don’t know why it wasn’t working with previous versions of UE4/OVR, but if updating the runtime doesn’t help, maybe it’s a permissions issue? To be safe, make sure the editor is launched after you plug in and turn on the HMD.

Yup, I figured it out too about an hour ago. I hadn’t thought to try anywhere other than the dev site for a download. Thanks!

OK now VR preview (For my DK2) is grayed out again in Unreal 4.14.3.

All research points to this page:
Unreal Engine Distributions

I just got no idea what it is that i need to download, plus half the links on this page are dead.
Has anyone managed to get the DK2 working on 4.14.3? How?


This download is a tiny 3.4MB installer program that’s trying to connect to the Oculus server. The problem I (and many other people) have is that it can’t ever connect. So we can’t download this version…
(Obviously I tried to run as admin and deactivate virus-scanner and exclude from firewall and so on)

Is there a direct link to the 844MB file somewhere?

Thank you!

-vr works like a charm for me at the command prompt (with my dk2)