VR not working with Oculus UDK 1

I’m trying with both 4.10 and 4.9 to do the following:

I’ve verified that Oculus is all set up (I can run it in Unity, and I did the showlog ovrversion verification).

When I try to run the VR mode, all I see is a black screen on the computer and all black through the Oculus. I noticed the ContentExamples project has the camera just pointing off into blackness, but if I move it into the lit room in front of the statue, it crashes when I try to play.

I also try with a 4.9 project and that crashed too when I tried to run it.

I also tried running the standalone version instead of VR, then using alt + enter to go fullscreen for VR, and that crashes the game too.


Using Alt+Enter, full screen, “clone desktop mode” not work anymore. You need install last version of Oculus SDK and install last version of nVidia drivers, which contain official GameWorks VR support.

I’ve reinstalled my NVidia drivers and this still didn’t work (I have the latest Oculus SDK and a brand new machine).

I was able to get it to work by forcing Unreal to use the integrated graphics card, but it lowered its playback quality because the frame rate was so low, and now, I can’t get it to render and high quality anymore (even when set back to use the NVidia card).

Last version of UE4 Editor launches standalone game with parameter -nohmd.
You can launch your VR project in two ways. The first way - use VR Preview in Editor. The second way - create package game for the Windows and launch it in the standalone mode.
These both ways work for me.

If you add to level blueprint this node, then your project always will run in VR mode