VR not working in 4.10 with HTC

Hi, when I try to use vr preview in v4.10, a window pops up, but nothing appears in the headset, and the controller input does nothing. The preview button is not greyed out, and it all works fine in 4.9.2
I’ve tried opening my scene from 4.9.2, as well as a new blank scene, and nothing works in VR in 4.10.0
Am I missing something?

Hello ,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Could you make sure that your drivers for your graphics card are up to date?
  2. Could you provide your dxdiag?
  3. Have you made any other changes other than updating to 4.10?

Hi Rudy, Thank you for your reply.
I am on windows 7, using a gtx 970, the driver is up to date at versin 358.91
link text

I’ve attached the dxdiag

The only other change I can think that was made was updating the oculus runtime to v.8

tested again this morning and still not working.

Im also having the same problems using 4.10 with my …does however works fine with 4.9.2

Hello ,

Additional questions:

  1. Just to clarify you are also running an oculus rift on the same machine?
  2. If so, are they both hooked up and turned on at the same time?
  3. If so, does unplugging the rift make a difference?
  4. Is your oculus rift experiencing the same issues as the ?

Hi Rudy,
I’m not running them both at the same time.
The DK2 seems to be working fine with 4.10.
The is not. I’ve tried running unreal as admin but still nothing going to the HMD except my desktop, and no input from the motion controllers. They both work fine in 4.9

I had the same setup regarding the and the DK2…
It all works fine with 4.9…
DK2 has been used on the computer, but is unplugged.
The is plugged in.
Cant get the HMD to work in 4.10 for the (not sure regarding the DK2)

OS:Windows 10
GPU:980GTX Evga
Latest oculus runtime and latest graphic drivers
(Not sure if this information might be of any help)

Hey ,

I do not see this asked in the post but what does the SteamVR overlay show you? Does it show you everything being all green or is everything all grey? Do you even have SteamVR enabled? If not you will need to download it from the Steam Client, install it, and then run it as SteamVR requires that you install and run the SteamVR tools or you will not be able to get the or Motion Controllers to work with UE4. Below is an image of what the SteamVR overlay should look like.



Please note that since I currently do not have my setup mine is all greyed out but when working, the above icons should be all green. Please let us know if this helps or not and if not we can try a few other things.

Hi Sam,
Steam VR is all setup and I have been using it successfully for a few months now with 4.9.
Normally with 4.9, I don’t need to have steam vr open. I hit VR preview, and the mirror window pops up.
Often times I will then have to click in the mirror window to pop it into the HMD, but it’s working reliably.

In 4.10, if I run unreal without steamvr open, and hit vr preview, the mirror window pops up, but does not allow me to click it, and only shows my desktop background. If I run unreal with steamvr open, I start with all 5 green icons.But once I start unreal, the HMD icon turns red with the “Compositor is not fullscreen” warning. I can click on “make compositor fullscreen” and get everything back to green again, but as soon as I hit VR preview, the HMD icon goes back to red. The mirror window also does not allow me to click it. But instead of just my desktop, I do get the grey 3d steam test world, with the controllers tracking. But my scene won’t pop into the HMD and the controllers aren’t getting input in my scene. This same scene all works fine in 4.9.

Thanks for your help. I also have another issue with getting objects to recognize hit events from the controllers.
Here’s the post I made about that.

Im having the exact same problem… all fine in 4.9… all fine when I start UE4.10 but as soon as I press the “preview in VR”-button, the HMD-icon turns red.
Just thought that I should share with you guys that Im experiencing the same issue… just to notify you that there are more then one “client” thats having the problem :slight_smile:

+1 here. Exact same problem. Worked fine with 4.9.2, integrated 4.10 and now it doesn’t work. VR Preview shows up, but nothing on the headset.

This bug is due to the way the Oculus 0.8 runtime reports back that it’s running, even if you don’t have a headset attached. We’re working on a workaround, but for now, use your Oculus Config Util to stop your Oculus service, and your should start working again.

You can also disable the Oculus VR plugins and then the should start working again.

Thanks Nick and Sam, that fixed it! Thanks again for your time.

My motion controllers are not shown in UE4.11.2. I had a working proof of concept yesterday but the controllers where out of batteries. Now when launching the poc it does not work anymore. Yes I have a Oculus DK2 setup with latest drivers 1.3 but the rift is NOT attached to the desktop. In the test scene (that worked yesterday) when I press the menu button on the motion controller, a menu is shown and the controllers are visible in the menu BUT when playing the scene they are not tracked. It did work yesterday so I have no idea what to do. I tried disabling all other plugins than the SeamVR plugin in the plugins section of UE (as suggested above) but still nothing is shown. The Steam VR is active and all lights are green which means setup seems to be ok. Any help is more than welcome.

After investigation it seemed to be related to a ChildActor being attached to the motion controller in construction script that failed both controller attachments without showing an error or warning message. Yesterday I did attached the Child Actor right before the batteries of the motion controllers went dead. Today I did not think attaching a child actor would be an issue but apparently it is. When I remove the ChildActor from the blueprint it worked again. Currently setting the actual blueprint to attach to the motion controller using a public property from the level blueprint (instead of a childactor) to the character blueprint and attaching it that way. It works…