Download

VR Not Tracking in Preview

Trying to use a VR headset on an existing project (previously worked fine with VR)
I’ve recently updated to UE 4.26 and I’ve been having an issue where my HMD won’t track (stuck in the initial camera position and wont move or rotate).

As a sanity check I’ve made a fresh ‘empty’ project, made a new pawn, added a scene and camera to it and added the “Set Tracking Origin” node to “BeginPlay”, put a ‘player start’ in the level and set the default pawn in the game mode. Testing ‘VR Preview’ and had no issues.

In my existing project I tried making a new level, gamemode, and pawn similar to how I did with the separate test project and the camera still refuses to update.

I’ve also tried:

  • Including auto possess player 0 in my pawn
  • Toggling Lock to Hmd (on by default, to off)
  • Using a pawn instead of the player start

Using UE 4.26.2, and Oculus CV1
I feel like I may have missed something simple, Any suggestions are appreciated.

The problem in my case was in the Play settings: I had Net Mode set to Client instead of Standalone. So I’m guessing the camera was stuck because there was no server to validate its movements, or something like that :slight_smile:
Thanks

Hi @TheIncgi !
I seem to be having the same problem in my project on UE5. Did you find any solution?

My camera is set to ‘Lock to HMD’, but it refuses to match the HMD rotation/position. It just sort of jiggles when I move the HMD, as if something is pulling it back each frame.

A fresh VR Template project works fine though. I’ve tried to set-up everything in my project like the VR Template, and I can’t see where this difference is coming from.

Thanks :slightly_smiling_face: