VR mode facing wrong direction

Hi guys,

When I launch my game in VR mode inside Unreal editor I am facing the wrong direction and I dont know how to change that. When I am running in normal mode I am facing the right direction.

I have setup a Pawn and I am rotating that however it only works in normal preview not in VR.

So I have tried to play around with blueprint but I have no succes. The Q and E keys works great but it cant be true that I have to do that everytime I start my game. Please help.

43728-capture2.png

Hi,
did you ever find a solution to this problem? I’m dealing with it too…

Ok, I solved it. This is absolutely weird, but it worked…

How do you change a lightbulb? You rotate the lightbulb? No, of course you rotate the room!

…I rotated my entire Level, all of the objects in it, the amount I needed (180°). It worked just like before on PC, and now it worked on GearVR too.

I see this on Blender for UE4 tutorials all the time where they tell you to rotate the mesh when you start so that it works properly with Unreal. Could it be that you aren’t doing that in your 3d program?

I’m using Blender too! But I must have missed the tutorials that you saw. Why would that matter? If it works in Unreal on developer mode, I don’t think it’s Blender’s fault if it doesn’t work after packaging on another device. Anyway I always export meshes after putting them in the origin (0,0,0) with no rotation (0,0,0); what is the correct setting?

That’s not a very satisfying solve! This is such an apathetic ‘community’ to not answer such an easy question. The answer: Have you tried pulling in a ‘PLAYER START’ object? They definitely give you a set place to start in a map and they pay attention to how they are rotated! (the Green Y is ‘forward’ rotate it to point where you want to look at VR OR FLAT runtime

Dude, it’s been almost two years.
As far as I can remember, yes, I placed a player start object. Provided that they existed and worked the same way, in UE version 4.7.
And this still doesn’t explain why it worked on PC but not on mobile.

Well, 2 years or 10, I believe there are a few people still learning the tool… :slight_smile: Absolutely it would make the difference: A PC game will default to the direction of the PAWN or Character etc. VR, Playstation, MAC and Mobile all benefit from a ‘Player Start’ object to further define your wishes,. That is indeed, why the object exists,. No 3D project (even PC) with a ‘player’ should be without a player start,

1 Like

What I mean is, 2 years ago there was version 4.7, now we have 4.21. Maybe the tool changed a little… :slight_smile: and maybe this issue disappeared.
Still, I don’t get why a PC game would default to the direction of the PAWN or Character etc. whereas VR, Playstation, MAC and Mobile would not; and on the opposite case, I don’t get why a Player Start would not be necessary for a PC game.

Two years ago or not, the issue is still there. Player Start has no effect whichever way you rotate it.

Hello - I had the same issue - tried a few things and then realised I move the computer so it had to be the sensors are the wrong way around - stupid mistake on my part but hopefully this will help someone else in the future - i didnt need to run oculus room setup, just swop the locations of the sensors around - no need to change USB’s. - Hope this helps.

I’m also a Blender user! However, I’m sure I missed the tutorials you saw. What difference does it make? If it works in developer mode in Unreal, I don’t think it’s Blender’s fault if it doesn’t work on another device after packaging. Anyway, I usually export meshes with no rotation (0,0,0) after putting them in the origin (0,0,0); what is the correct setting?
smash karts

And three years later I must say THANK YOU! The “VR player start” is just what I needed.