Download

VR HMD lags behind character mesh

So I’m creating a VR pawn with a full body skeletal mesh. I am trying to avoid using FABRIK due to recent issues with clothing.

But the HMD camera lags behind the characters mesh when I am moving with locomotion (sticks) and I can see inside it’s head/behind eyes.

  • If FABRIK OR TwoBoneIK is enabled on the Head Transform, it works. (But causes stretching clothing).
  • I followed the VR Cookbook and Mitch’s VR Lab.
  • All clothing attaches using “Set Master Pose Component”.

What would be a good approach to this problem?

VR_Setup

The brute force option is to just hide the head when rendering from the players perspective. There shouldn’t be any point in rendering it either way, apart from shadows and reflections.

I thought about this but I would need to create a dynamic material mask that changes depending on the owner. But then I imagine I would still be able to see inside the rest of the body as well?

I’m gonna try a different approach. I just watched this tutorial and noticed that the VR scene is a child of the mesh. Just set it up myself and it looks plausible. I’ll test it when I can and report back.

Okay that did NOT work. So I decided to work with the interpolation from the mesh to the camera location. The trick was to change the “Mesh World Location” to the “HMD_Socket” location instead. FABRIK is not enabled. Everything works flawlessly now.

1 Like