VR Expansion Plugin

Ah I finally figured it out, I restarted and did everything with your latest template project. Turns out I had to set Simulate Physics on the Skeletal Mesh, this is not needed for the Static Mesh.
Hope this helps everyone!

Shouldn’t have to do that either? It will auto set simulate physics if the grip type needs it.

Did you set simulating to false somewhere in some new nodes and override the plugin?

Actually I manually added the plugin to a blank project and then I added to it the template resources in order to see how it all works.
That’s probably why it didn’t work, I didn’t clone the latest commit with all the new features, I directly downloaded the most recent pre built version of the plugin (4.19).
Anyway, problem solved for now. Thanks !

That isn’t a new feature, its been in since the beginning, you must have unlinked nodes from transitioning.

Those “errors” don’t tell me anything, there is no actual error message there.

Post the rest of the log

I did recently move some inline functions around to help with ps4, I know a couple of users are already on the platform.

I solve my grip position problem by my self.

The physic shapes must be attached under root, now its possible to use VRGripP1 socket in the skeletal mesh.

Pushed a new commit to the plugin

Whoops, was using wrong logic for the new snap turn introduced in the last patch.

Fixed and added a new option to SetActorRotationVR while I was at it.

Also removing a capsule offset override that was preventing clean projects from
getting the 2.15 UU offset for the capsule to correct for the movement components

I am compiling the pre-compiled binaries now and will update them when complete.

Edit New binaries uploaded

Just virgin demo-project without any my changes. Though I packaged other PS4 projects without your awesome VR plug-in and it’s goes well ofc. Here your log:

Hi there! The plugin looks great, I’ve had my eyes on it for a while. I want to see the example scene because I need the setup for the vehicle. I successfully installed the plugin for 4.18 and downloaded 4.19 to check out this map. When I generate the Visual Studio files, I can successfully build the project there. When I try to open it, I get multiple error messages regarding missing modules. I deactivated all plugins and still have the error with a missing AdvancedSteamSessions.dll. I tried to move the contents to a new 4.19 project, but then the map I need is completely broken and misses a floor, guns and the car.

I’ll try to download a new VS version since I was using 2015 until now. Maybe it’s that.

EDIT: Same problem as before. It builds just fine without errors or warnings in VS, but if I try to open it:

“The following modules are missing or built with a different engine version:
Would you like to rebuild them now?”

Yes -> “VRExpPluginExample could not be compiled. Try rebuilding from source manually.”

The template download is a complete package, it has both of the plugins it uses already packaged in with it, you just have to compile it as-is. If you downloaded the plugin separately you shouldn’t.

If compilation is an issue for you, the current template should be compatible with the pre-built 4.19 binaries of both plugins as well. I have Advanced Sessions packaged in for the server browser portion of the example template.

Ah, well that was easy to diagnose, the real issue was right at the top of the log.

Disable the AdvancedSteamSessions module in the plugins list, there is no Steam binaries packaged out for PS4 and since you left the module enabled it is expecting them.

I don’t use that module in the template anywhere currently, it is just active by default when AdvancedSessions is installed.

You’ll likely also want to disable the SteamVRExpansion module since that is also unusable in PS4, it will show BP errors for the few nodes that the main character uses from it so you can just delete them. I wrap all of the OpenVR functions in pre-compiler checks so it might package out with it enabled, but the nodes will do nothing.

the last warning is it complaining about some logical syntax, their compiler isn’t as fine with it as others are, i’ll clean that up too, it would still build with it, but errors messages clutter the screen and it is a valid warning that should be fixed anyway.

I don’t have the two problematic plugins installed for 4.19. (AdvancedSteamSessions, OpenVRExpansionPlugin). The build does work according to VS (both 2015 and 2017), but I still get this error when I try to open it. The .dll of these modules exist though.

What do you suggest? Installing both plugins for the 4.19 engine and try to compile Plugin Example Template Repository again?

Build for Development Editor, that is the one that opening the editor requires.

His problem is PS4 specific, its unrelated.

The plugin won’t “auto compile” when launching the editor, has to be done from visual studio. AFAIK that message box only works with engine folder installed plugins.

Thank you very much sir, but, can you give me a tip please - how can I disable SteamVRExpansion module? IDK how to this do but also I can’t to find any mentioning of this in source files too to just delete them…

Go to the top of the editor, and the Plugins menu

You can turn off any module in the engine from there.

Thank you so much for your help so far! I wasn’t referring to a comment from another user, I’m sorry if this caused confusion. My error message in the first post just happened to contain this:

“The following modules are missing or built with a different engine version:
Would you like to rebuild them now?”

I did follow all the steps from the readme:
I downloaded the Plugin Example Template Repository
I right-clicked and made sure it says 4.19
I generated the VS files
I opened the .sln in VS and selected the Development Editor Win64
I build solution (also tried to clean or build it individually)
It finishes without errors and warnings
I open the .uproject and get the errors mentioned above

Did I make a mistake at some point or did I forget something?

The Plugin Example Template Repository is the only one that contains the complete car, right? Or can I find it somewhere else?

Sorry, but I’m a little confused… Do you mean a whole OpenVRExpansion plugin by naming it as SteamVRExpansion module, so you say that I just should turn it off?

No, in the actual editor there is a menu item called “Plugins”, it shows visual list of all enabled plugins, you can disable those two in there. Just turn them off and they won’t package out.

Nope, that should be working, what platform are you on that those two aren’t compiling? You can open the uproject and remove the OpenVRExpansionPlugin from the list of modules it uses, and you can delete the two modules that aren’t compiling, but if there truly is no warnings than it should load fine.

I have Windows 10. I tried to turn it off before (I simply selected enabled: false in the .uproject), but I still get the error regarding AdvancedSteamSessions. The only way I was able to get rid of this one as well was by removing the AdvancedSteamSessions folder. It doesn’t seam to be a good idea though because the project crashes if I want to start it afterwards.