Download

VR Camera seems off in 4.11.1?

When I rotate my head. Seems it rotates on a strange and bigger circular axis. It’s all sorts of messed up.

Just converted my project and everything seems good.

The camera system was refactored in 4.11, so you might have some weird cameras in your pawn/character that weren’t being used before.

So much black smearing though… (DK2)

[QUOTE=Alexotronic;508455]
Just converted my project and everything seems good.

The camera system was refactored in 4.11, so you might have some weird cameras in your pawn/character that weren’t being used before.

So much black smearing though… (DK2)/QUOTE

Ya the black smearing is crazzy…

Try turning off the “Lock to HMD” setting on the camera component. I suspect it plays poorly with older devkits.

Actually its the “Use pawn control rotation” in your character’s camera that is causing the weird rotation. Disable that and everything will be perfect.

Thanks tcla75. Works now!

I’m also having that problem, and your suggestion seems to fix it, but creates a new one: now my player movement is completely disconnected from the look direction. If I rotate my body while playing, everything gets absolutely confusing, and I have to physically find my original forward direction to continue playing.
Any other suggestions would be deeply appreciated.
Thanks in advance!

I’ve only just noticed this now that you have pointed it out. I usually test the game sitting down and turn left or right with the right thumb stick. This is a big problem if you are trying to have a standing experience. It could either be a bug that Unreal need to fix or hopefully someone knows a way to get rid of that stupid distorted view when you turn while keeping move in the direction your head is turned.

Someone in answerhub gave the following answer.

"I ran into this, as well.

The problem was that the automatic HMD tracking stuff didn’t take into account the rotation of the pawn. If your pawn is rotated in any axis (most likely yaw from your player spawner being rotated in the level) then you’ll end up with the HMD tracking axes being misaligned.

Just make sure your camera component’s parent component is always aligned with the world axes and you should be okay."

I’m not really sure what he means by “aligned with the world axes” if he means scene component X Y and Z being the same as the camera then that doesn’t work. My camera component doesn’t have a parent so hopefully someone else here might understand what he means and explain it here.

As a low-intermediate UE4 developer, that points me to a direction that I’m not sure how to follow. What bothers me is that it worked effortlessly before, which indicates it’s a bug from the recent update. I hope it’s fixed soon, as fixing it by myself would require time and effort I can’t afford.

Okay, I got something here. I unchecked “Lock to HMD” and kept “Use Pawn Control Rotation” checked. It was still weird, as if the camera was not on the real axis of rotation. So I actually moved the camera pivot to the center of the Pawn’s capsule, and now it works perfectly.
TL:DR; Uncheck “Lock to HMD” and move camera to center of capsule.
Please, report back if it works for you.

This works for me! My camera worked with “Lock to HMD” on the last version and even this version before the library update they had on this version. But anyways turning off “Lock to hmd” and positioning the camera in the center of the capsule (x and y) but not z and it still works.

I tried this with the Oculus Touch controllers. It doesn’t work well with them. Movement is no longer 1:1 with your hands and what you see on screen.

This is a pretty annoying problem to solve. I think gen1 VR is going to have to make some unpopular compromises.

Bino, have you tried turning turning on ‘Lock To HMD’ and unchecking ‘Pawn Control Rotation’? That’s the usual way of doing it, (as per the UE4 VR videos, etc.).