Download

VR and fullscreen mode

Hi all,

I wasn’t quite sure where to post this issue seeing as it might not be related to VR. I’ve been working on this project - pretty much an asset showcase level - and I was using the “fullscreen” command without any issues. I just hooked up the rift and updated my driver from 361 to 364 and got it all working, however fullscreen does not seem to have an affect anymore. I would like to be able to play the level in fullscreen while in non stereoscopic mode. As far as I can remember I’ve reverted everything I’ve changed which isn’t much. I’m in 4.11.2, I’ve enabled instanced stereo, i’ve disabled lock to hmd, changed the height of the camera and that’s about it. I reverted all of those settings and even rolled back on my drivers but it still hasn’t helped.
Any help would be much appreciated :slight_smile:

Yeah the fullscreen command does not seem to work anymore with it in 4.11

Ahhh wonderful :slight_smile:

yeap, I did find this thread describing the issue and a possible fix for it

unfortunately my game still starts up in windowed mode and is partially off screen.
Imgur

I can only get fullscreen working if I type fullscreen into the console command after it has initially loaded up.

You are running 2 monitors outside of the vr headset itself right? I tend to have that problem if the positioning of the screens is in a straight line. Try putting them vertically as a quick test and see if it still happens

I am running multiple monitors and did try out your method with no success.
I just tested out a blank project and successfully got fullscreen working on startup of a standalone game so it looks like there’s some setting that I changed within my project which I’m just going to have to dig through and find.

Tried this method again https://forums.unrealengine.com/showthread.php?107173-Console-command-quot-fullscreen-quot-no-longer-working-with-4-11-1&highlight=fullscreen
and everything seems back to normal

Edit: Thanks rrstuv

That link does not work.