Download

Volumetric Godrays and Ray Tracing

Trying to create a ‘god ray’ effect on an interior shot. I get my desired effect when I disable Ray Traced shadows on my sun 9Directional Light) but the effect is broken the moment I enable cast Ray Traced shadows.
Can any lighting experts suggest why and is there a solution?

Volumetric shadows are not yet supported by ray tracing. Here’s a workaround:

  1. Duplicate the directional light and parent it under the first.
  2. Select the first directional light and set it’s volume scattering intensity to 0.
  3. Select the second directional light and uncheck “cast ray tracing shadows”.
  4. Dial it’s intensity way down to 0.01 and it’s volume scattering intensity way up (in my case 15000).

This way your first directional light acts as the main light source and the second is just there for the volumetric lighting. Of course performance wise you’ll have to pay for two lights instead of one.