Volumetric fog rendering in one eye


I’m trying to get volumetric fog working in VR in 4.27.2 So far its only correctly rendering in the right eye. It is somewhat visible in the left, but is offset. I have tried both forward and deferred shading, toggling vertex fogging for opaque and toggling instanced stereo. I also created a local volumetric fog via a volumetric materials/particle system, and am having a similar result regarding visibility. Is there any way to get volumetrics work correctly with VR (PC run)?


Same issue… In some levels with fog it’s visible only on 1 eye. In others where there is parametric clouds they are visible in front of any geometry but only on 1 eye, in the other is correct. Anyone resolved this issue?

You may want to try adjusting the settings for stereo rendering in the project settings. Specifically, you can try adjusting the “Stereo Layer” settings for the fog component, as well as the “Stereo Rendering Mode” for the camera. Additionally, you may want to check for any updates or known issues related to volumetric fog and VR in the Unreal Engine 4.27.2 release notes, or the alternative version you are using.

Another way to solve this is to use a custom depth pass to render the volumetric fog. This ensures that the volumetric fog is rendered correctly in stereo.

Finally, you can also try to use a post-processing approach to achieve a volumetric lighting effect. This way you can avoid stereo rendering issues altogether. Something like this: Elias Wick | Fog