Download

Volumetric fog disappears and reappears by moving camera

Hi,
I have a strange issue with volumetric fog particles.
I have a scene which is an asteroid belt.
I want to add some dust to it, so I add volumetric fog within the belt.
I do this by adding ExponentialHeightFog into the scene, then generate the Particle system.
The result looks good to me.

So far so good.

Then I move the camera towards (or also away) the asteroid belt, and the fog disappears.

Confused, I move my camera around, and I see that the fog is still there, in the other sections of the belt.

Then I look back to the original camera direction, and the fog is back.

This happens both in the editor and during gameplay as well.
Could the problem be the scale of the scene? It’s in a very big scale, the size of the images should be around 100-500k in width.
Anyone has ideas of what I’m doing wrong?

Thanks! :slight_smile:

Could be that the size of the render is casuing stuff not to render…
Check RHI stats to see what tris count and scene stuff you have going on.

My 2c is that you should just make the fog into fog sheets…

What other parameters are on the scene?
Is it dynamic or static light for instance?

Hi MostHost,
thanks for the answer.
I was not aware of the RHI Stats :slight_smile:
Here is a screenshot of while looking at the fog, as before:

What I found out is that this effect seems to be independent of the settings of the Material Instance I’m using. Just, if I use a higher Albero, or Hardness, or Extinction coefficients, I notice less the issue. But it’s still definitely there also when the fog is more dense: when I move the camera around, I can see the nasty signs left by the camera into the fog.

Light: static is disabled, only one dynamic directional light coming from the direction of the sun.
There is a very weak SkyLight.
There is a PostProcessVolume with Exposure Compensation On and Min and Max Brightness settings. They have no influence on this fog issue, I verified by turning everything On and Off.

Did you ever resolve this? I’m running into something similar.

Hi geei, unfortunately I could not find a solution.
It seems that this issue might be built into the engine :frowning: