Volumetric Clouds Causing Rendering Issues

When I add volumetric clouds and look to the planet from above weird graphical glitches appear. Happens in the example Time of Day scene when you delete the SkyDomeMesh. Is there a way of using Volumetric Clouds and not having this?

This is because the directional light on that level has Cast Cloud Shadows enabled (to cast shadows in meshes and atmosphere). And for that to be used for special space view use case, you need to set the shadow map extent very large (expensive for high quality). Please read Volumetric Clouds | Unreal Engine Documentation . If you do not care about shadow from clouds onto atmosphere then you can simply disable that option.
I hope this clarify what is happening.


Thank you for the explanation! Really helped.